Problem converting from Anaconda Python to ActiveState Python

I just tried to describe the problem that I am having installing python. When I clicked on Create Topic, a widget appeared telling me that new users could not have more that two links. I assume that means URLs.

Cutting to the bare essentials, I was running the script from ActiveState’s The Anaconda Alternative page. It seemed to have installed the State Tool Package Manager and went on to Creating a Virtual Environment. Then it wrote:

Creating a Virtual Environment for your Project’s Packages

This project will be set as the default, meaning you can use it from anywhere on your system without activating.
Resolving dependencies 0 / 0 \ 0 %

Something Went Wrong
x Could not update runtime installation
x Could not resolve recipe for project ActiveState-Labs/Anaconda-for-ActivePython-3.9#28814b8e-f82e-4963-9171-abedec9b6fa8
x Unknown error resolving order"


This does not provide me with a clue about how to proceed. Any assistance that can be given will be truly appreciated.

Mack Elrod

Hi there!

I just tried the default activation (the powershell script you get when clicking ‘Install’ on the windows version) on a fresh Windows 11 install and it worked fine. My guess from the error message is that you’ve tried to state activate ActiveState-Labs/Anaconda-for-ActivePython-3.9 on a windows machine. Unfortunately, that’s probably not going to work in this instance as the project has separate branches for windows, mac and linux most likely because there are some incompatibilities across platforms for some of the modules. On Windows, that means you’ll need to specifically activate the windows-version branch like so:

state activate ActiveState-Labs/Anaconda-for-ActivePython-3.9 --branch windows-version

Hopefully, this should work for you.


Thank you very much, Shaun.

Tomorrow, I will give this a try.

With regards,