Activestate phython: python -m venv VIRTUALENV fails (V3.7.4, 3.7.8, 3.8.8)

I have downloaded a 3rd party python program which suggests using a virtual environment to isolate its pre-req modules from those in rest of the system. Active State python 3.8 is in my path (along with the DLLs, tools, etc. etc.) When I try:

python -m vent VIRTUALENV

The response is:

Unable to copy ‘P:\Pro\Python38\venvlauncher.exe’
Unable to copy ‘P:\Pro\Python38\venvwlauncher.exe’
Error: [WinError 2] The system cannot find the file specified

The programs venvlauncher.exe and venvwlauncher.exe do not exist on my system anywhere (I started with V3.7.4, tried the latest 3.7 and 3.8 - made no difference).

Any suggestions?

HI @cube1us ,
Thank you for posting here! The team advises installing ActivePython using the StateTool - state activate! Let us know if that works.

Specifically, the state tool is ActiveState’s virtual environment and package manager. See the state tool intro for more details on how to install it and how to use it to install ActivePython releases


Well, that’s interesting. With V3.7, there was a state.exe installed, but it was installed under the user doing the install, in that user’s roaming profile. When I installed V3.8, there was no corresponding state.exe . That made me verrrry leary of the “state tool”.

However, what I DID find is this page (see below) which suggests one can use “-m virtualenv” instead of “-m venv”, and that was indeed already present in V3.8, and it worked just fine.

The are other pages on the Activestate web site that suggest “-m venv” is supposed to work, but as I posted originally, it didn’t.

So, Python is already descending into “PIP Hell” which corresponds with Perl’s “CPAN Hell” - and provides yet another reason why I dislike Python (in this case, the provider of the code I wanted to use has used Python for prototyping, so I didn’t get to choose the language used.)