ActivePython 3.8 install fails when preparing environment, no error given

I can’t install ActivePython 3.8 nor 3.7, both fail with the same error… or lack there of. See image below.

Any ideas?


Hi Dustin,

What version of Windows are you installing this on?


Whoops, sorry, I guess that would help.

Windows 10 Pro for Workstations
Version: 10.0.19043 Build 19043

I tried installing to the default path it gives:

Thanks for looking into this!

I would like to also mention, I was able to successfully install 3.8 on a different Windows computer with no issues. In the process of doing so, I think I know what might have happened.

During the first install on my Laptop (the one where the install currently fails). I don’t think it ever finished. I remember that last part taking forever. During the last part of the installation, my computer performed a “Restart” due to another installation I was doing at the time. I believe the restart messed up the initial install of ActivePython 3.8.

So because the install never finished, something is broken. Now when I try to install, it encounters an unknown error.

Is there a way to perform an “uninstall” for the program that my computer does not recognize as “installed”?

Like are there certain directories I need to delete within the windows system? No directory or files were created in my install directory of “C:\Python3”.

“preparing environment caused error”
is not an error message that can be generated by any part of the code in the installer that was written by ActiveState, and I don’t get any hits when I search for that error message elsewhere. That might mean that the message comes from an AntiMalware utility. If this computer has AntiVirus or a security suite running, that might be what blocked the original installation. You might be able to disable your antivirus and try rerunning the installer.
The MSI installer will offer a repair option if it detects there’s an instance already present. It is isn’t finding anything, that might also indicate that the original attempt was diverted into a “sandbox” by your AntiVirus software. Taking a very long time is a symptom that files are being scanned by A/V software. If the instance is still in the sandbox when the system restarts, the A/V will probably know it was sandboxed and not installed, and might interpret that as having failed some scan.

1 Like

I disabled my Windows Antivirus and Firewall and tried to install. I get the same “preparing environment caused error” message :frowning:

I installed version 2.7 on the computer and that seems to work fine. So I guess I can just use the “old” version.

By chance, is there a way to “upgrade” the old version besides downloading and installing via the 3.8 installer? I’m just looking for an alternative method as the installer does not seem to work for me for the 3.x versions…

Would a virtual environment deployment work for you? You could try out a State Tool powered Python 3.9.