Python 3.8.2 will not be installed in Windows

I’m downloading the MSI, but if I execute it Python will not appear in program folder. Even the path-variable will not be changed. It shows that it is installing, but when it says it is ready Python is not there. There is no error, nothing. I’m executing the MSI for Windows and it is installing and nothing happens…

What am I doing wrong? Do you have any ideas or can you send me a stable MSI, please?

Thank you very much for your help and have a nice day!

If you have a Security Suite (or restrictive Policy Settings), you may need to disable your antivirus before the installer can run. I have seen cases where it was necessary to run the installer from the command line started with “Run as Administrator” and logging on. In that case, once the base folders were created, the installer could be run repeatedly without any further issues.

Thank you very much for your answer, but disabling our security suite is not an option. We are a company with around 3000 users that would be a risk. The installation process should be automated. I’ll try to install it with administrative rights. I’ll come back to you and inform you if that was working. We have had no problems with version 3.7.x we could automate the installation very easy. We downloaded the MSI and installed it. What’s strange for me, the 3.8.2 is installing the setup comes to that point where it is ready and everything was done, but nothing was done - there is no error, there is really nothing, I’ll keep that in mind and I’ll check what our security suite is doing while Python is installing.

Ok, I tried it with administrative rights and I tried it as an administrator and command line. The result is still the same. I checked our security suite and it was very active. I think it is a problem of our security suite but there is no way to deactivate it. I need a test-computer for that case, now. This will take a bit longer… We are using GData. Do you have any experience with it?

Are you installing 3.8.2 to a folder with white space in the name? That will hit a blocker right at the end of the installation and roll back. It’s possible to miss the warning message, and not see that it failed to install.

The default target has no white space. Can you try that and see if you get it to work?

Thank you very much for your answer. I’m using the default target. I’m convinced that it is a problem of our security suite (GData), but to figure that out it will take more time. I could not easily stop GData - this would be against our security guide. I hope I can test it within the next two weeks and than I’ll come back to you. It’s not easy to get a test-computer within Covid-19 home office… :slight_smile: Take care and stay healty!