My project broke, even if reverting to earliest...even it starting new project it will not build?

I returned to an old project I’d built back in March to apply pending updates to eliminate CVEs.
I had previously tried adding modules, but failed, and reverted to the last good spot, and that’s
where I started today. But at some point I was seeing Glibc 2.17 in logs instead of Glib 2.12,
however if I downloaded and tried to run its perl-static it ran ok and ldd reported no issues.
Anyhow, it broke when trying to build with the upddates, and ever reverting to the initial branch ID failed to build without error…and perl itself was one of the things being complained about.
This was project, Perl-5.32.1-Linux-CentOS-Debian7

I then tried to create a new project,

Perl-5.32.1-Linux-CentOS-Debian7-Wheezy

I initially chose to include 3 bundles, but that failed. I then tried to remove these, leaving only the bare new project, but it also fails. Logs complain of several symbols/medhods not found.

How can I get back on track ???

Thanks

Your project is still set to attempt a build on Glibc 2.12. Try switching away from Centos 6 to Glibc 2.17 or 2.28.The latest versions of our builders are removing support for the old 2.12 version. Also make sure you have “Auto” selected as the desired version of any modules or bundles that will let you chose Auto.

If you really need support for Glibc 2.12, you should talk to our sales team about the Enterprise Extended Support versions.

1 Like

Hi,

I successfully built a new 2.17 project to replace the 2.12 one that stopped working.

But I’m having trouble getting it to download……what do I need to do ?

Thanks,

Steve

[tdsmichl@cilv6s797 ~]$ sh <(curl -q https://platform.activestate.com/dl/cli/install.sh) --activate-default tdsmichl/Perl-5.32.1-Linux-CentOS-Glibc-2.17

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0Installing the State Tool …

100 12880 100 12880 0 0 33132 0 --:–:-- --:–:-- --:–:-- 33110

╔════════════════════════════════╗

║ Activating Virtual Environment ║

╚════════════════════════════════╝

Existing Checkout

You already have this project checked out, which one would you like to activate?

/home/tdsmichl/tdsmichl/Perl-5.32.1-Linux-CentOS-Glibc-2.17

None, I want to create a new copy

Something Went Wrong

────────────────────

x Could not update runtime installation

x Not all artifacts could be installed:

Failed to install artifact Text-Tabs+Wrap (10d66c23-fa73-5e2e-8bda-65fed133e6f3) :: Invalid status code: 404

Need More Help?

───────────────

• Run → state activate --help for general help

• Visit the Forum → State Tool - ActiveState Community

[tdsmichl@cilv6s797 ~]$ state projects

╔══════════════════╗

║ Listing Projects ║

╚══════════════════╝

Name Organization

──────────────────────────────────────────────────────────────────────────────────────

Perl-5.32.1-Linux-CentOS-Debian7 tdsmichl

└─ :heavy_check_mark: Local Checkout → /home/tdsmichl/tdsmichl/Perl-5.32.1-Linux-CentOS-Debian7

Perl-5.32.1-Linux-CentOS-Glibc-2.17 tdsmichl

└─ :heavy_check_mark: Local Checkout → /home/tdsmichl/tdsmichl/Perl-5.32.1-Linux-CentOS-Glibc-2.17

perl-5.32.0-linux-centos tdsmichl

└─ :heavy_check_mark: Local Checkout → /home/tdsmichl/AS/tdsmichl/Perl-5.32.0-Linux-CentOS

[tdsmichl@cilv6s797 ~]$

2 Likes