Build has not completed after 22+ hours. Only added 2 modules, both of which built ok


Elapsed time continues to update, but module count stuck at 702 of 765 since yesterday.

Previous commitID built fine, (9de115fa-b2e2-4e93-ad48-264d05cd0390).
Just tried to add 2 modules that were missing. Both were successfully built. 63 still queued.
There were 2 commitIDs after this, 1st tried to add DB_File, 2nd removed it after build failed.

What should I do ?


Hi @tdsmichl - I’ll check on your project with the builder team and get back to you!


@tdsmichl it looks like there was a hiccup in our build system. The team is creating a script that should unblock your build, I’ll let you know once it’s been run but if I’m out for the day by then you should also receive a build notification email in your inbox when the build process finishes running.

Thanks for the quick respone :blush:


Hi @tdsmichl - looks like your build got stuck again in the same fashion as before. The team is looking into it again. They suspect a part of the issue is just the size of the build, with 700+ packages. While they’re working on resolving the issue, is there a smaller build with fewer packages that could still work for you in the meantime? The bundles bring in a ton of packages - you could create a copy of the project with the “Fork” button in the project header and try removing packages you don’t need.

Cheers - I’ll post updates when I get them.

Thanks, it was much closer, lacking only 2 of the 765. Lacking only Catalyst and Catalyst-Plugin-Cache.

These were likely pulled in by some of the newer modules and were not part of the perl v5.8.8.320 I’m trying to upgrade from.

The two modules added for this build were missed until recent testing.

The only other module I’ve been waiting for was being worked by zakg



Steve Michel


@tdsmichl Yeah I’m guessing they were brought in by one of the packages in the Catalyst bundle. It looks like your project has a bunch of Bundles included…

Just want to double-check that that was intentional as they can be removed and the project can rebuild with fewer packages.

I’ll check with Greg about the other post and see if he has any updates.


1 Like


Looks like removing the Catalyst bundle allowed it to complete
Fortunately I have no direct dependencies on it, although it has lots of dependencies itself.
Do you know a reverse dependency reporting mechanism ? (other than grep) ie. What installed modules depend on Catalyst ?



“What installed modules depend on (x)”
There are no simple, good, options available.

We have some in-house tools based on what we’ve learned since we started The Platform, and there’s a fairly high likelihood that some version of those tools will appear on The Platform as part of a future UX. It’s a feature that would be very helpful when users need information on what’s bringing in any ingredient that they don’t want or can’t consume.

Thanks - something to look forward to :slight_smile: