"Bad Request" with no explanation

I created a Perl package and added all the necessary packages to it. When I finished, I wanted to ‘Download Builds’ - I see a red popup box ‘Bad Request’. Why is that the case?

Hi @david-roy - thanks for bringing this to our attention. We’ve filed an issue to better handle that error state. Unfortunately, our system is having trouble building of the dependencies in the build: libgd. There’s work in progress to address it, and it’s estimated it will be done by the end of the week or early next week.

I’ve let the team know about this post and they should be posting a follow-up here when the issue is resolved.

Another option would be to switch your Perl version to 5.28 - though there’s a different issue with that build that is cropping up, but there’s work in progress to address it in the next day or so.

1 Like

Following up on this - do you have the latest status on this?

Hi @david-roy - I’m testing a build now to see if it’s resolved. Will post results shortly.

@david-roy I didn’t have much luck - I forked your project and then kicked off a new build by changing one fo the versions of the packages to a specific version so that it would rebuild, but then ran into build failures as you can see here…

https://platform.activestate.com/flukeout-hold/Perl-5.32.1-Windows-Linux-RedHat-fix/distributions

Quite a few packages failed to build - more than the team is able to triage at the moment. One way forward could be trying to remove those failing packages from your build which you do not absolutely need.

Otherwise, we maybe just have to wait for more stability in the build system before this will build.

I looked at the failures and see that only 1 (Tk) needs to be retain. I removed others from the build package. However, tilefall package was added base on dependency – I am not sure which requested packages depend on tilefall package. Oddly, all of other packages compiled, I would expect at least one said ‘not attempted’ based on tilefall package failure. So, how can I remove tilefall if no real package depends on it?

I tried all Tk versions out there with no success – and this is needed – do you have an ETA on this fix?

@david-roy The Tk issue is in the queue to be worked on, but unfortunately there’s no estimate for when it might be done at this time. I investigated some other builds that were using it, and came across

https://platform.activestate.com/ActiveState-Support/ActivePerl-5.28-Tk/distributions?platformID=0fa42e8c-ac7b-5dd7-9407-8aa15f9b993a&branch=main

Which did build successfully - but I can reproduce the success when I changed your project to the same language version and glibc version as the one above.

I tried the same (change Perl version to 5.28.1 & glibc to 2.17, update Tk to Auto) like you did but it failed for me. I got build failure on libxslt. How were you able to get success?