Is it possible to have Komodo 12.0.1 without State/Platform?

I have installed Project using State, worked fine at first. Now terminal will not work correctly reports

setupterm(term=_os.environ.get("TERM", "unknown"),

_curses.error: setupterm: could not find terminal

Can’t state install packages… example
state install pep8 Won’t work!
pip install pep8 Won’t work!

PLEASE make it so can use Komodo 12.0.1 like I once could to right code and not have state mess up everything. Spend more time trying to use State then writing Code.
If You could use a survey to find how many people have problems with State/Platform you might try to have version of Komodo without State for us that can’t make it work.

Would you happen to be using csh normally?

If by csh you mean curses in the shell, konsole, bash shell? Yes, writing python shell program in Curses.

Worked fine till tryed using, now won’t run with Komodo. Reports something about terminal not known.

Correction: pip will install pep8, state won’t install pep8… used state first then pip.