How to add a module to an existing Perl installation on Win10?

Hi support team,
I have searched the posts of the community, but unfortunately I could’nt find an answer to solve my problem. I succesfully have finished a build for my project (Perl 5.28.3 Win10) online. After downloading and installing my build using the .exe, I recognized that I forgot to include a module.

As described here (Goodbye PPM, Hello State Tool - ActiveState), probably State Tool could help to install/add the missing module to my Perl environment. I read the docs and tried some things, but no success.

So, how can I add a module using State Tool? Is there any guide availlable, e.g. how to do it step by step? Or is it necessary to modify my project online/offline and completely do a rebuild of my project?

Thanks in advance for any reply.

You can only add a module to the installed Perl if the installer was The State Tool.
5.32 and 5.34 use The State Tool to install. The first thing that gets installed is the latest version of the State Tool, and if you used “state activate” the installed build is still connected to your online project. When you add modules to the online build project, they can be downloaded and installed into the build on your system.
If you used an older version of Perl, like 5.28, you don’t have The State Tool, and you can’t use the State Tool to add modules. You need to add the module to your online project, rebuild to get a new installer, remove your old version and reinstall with the added module.

Thanks a lot for quick and detailed response. I’m going to think about using versions 5.32 or later.

Allow me one further question. I have installed state tool running behind a firewall and a proxy. Installation completed succesfully but I can not conncet to the platform. Using ‘state auth’ and entering my credentials fails.
The error message is as follows:
Something Went Wrong
x Could not authenticate
x Authentication failed
x Authentication failed due to an unknown cause, error received: Authentication failed: Post “https://platform.activest”: context deadline exceeded
Is it necessary to configure proxy settings, and if so, where can I do that?

Setting the https_proxy environment variable properly solved my State Tool connection problem. State Tool is working now. I leave the above quoted text for others who might run into the same problem.

Thanks a lot for your efforts.