Help with Installation/State Tool on Windows 10

My IT department recently provided me with a new Windows 10 PC to replace my Windows 7 where I was using ActiveState Perl 5.26 and PPM to manage packages. The new installed version 5.28. I am trying to use the state tool to install several packages that I need (Win32-OLE for example) and I receive the following message:
Failed to add package
Error occurred while trying to update a branch: [PUT /vcs/branch/{branchID}][403] updateBranchForbidden
&{Code:0xc000496470 Message:0xc0008cc0c0}

Not sure what is going on, when I look on my ActiveState account it doesn’t show any projects even though I have activated my build on my PC.

Thanks for any help,
Jim Crust

Hey @crustjb!

Thank you for the note!

I’ll ask one of the team to look at the error. In the meantime, can you share what you did before getting the errors?

Cheers!

Hi Zak,

Thank you for your response. I tried several different things but basically, I installed version 5.28 from ActiveState and I am attempting to add some additional modules (Win32-OLE, tk, for example) to the installation. I will list below what I am trying to accomplish and it might be easier if you can let me know the steps I need to take to accomplish this.

On my previous machines, I had ActivePerl installed around 2 years ago, and when I needed additional modules, I used PPM to add them to the installation. I haven’t needed any new modules for a while, so I hadn’t realized that ActiveState had transitioned away from PPM and to the new State tool. When I received a new machine from our IT department, they installed Perl and I tried to add the modules I needed but was unsuccessful. I don’t need multiple development environments, I just need a Perl installation where I can add the modules I need. If you can provide me that steps I need to follow to do this, I would really appreciate it.

Regards,

Jim Crust
Steam Turbine Development
Elliott Group
901 North Fourth Street
Jeannette, PA 15644-1474
724-600-8406 - Office
724-875-9753 - Cell
jcrust@elliott-turbo.com

CONFIDENTIALITY NOTICE: This E-mail, along with any attachments, is considered confidential and may well be legally privileged. If you have received it in error, you are on notice of its status. Please notify us immediately by reply e-mail and then delete this message from your system. Please do not copy it or use it for any purposes, or disclose its contents to any other person. Thank you for your cooperation.

Hey Jim!

I think that I know what’s going on. It looks like you tried to add a package to a stock install of ActivePerl, when what you need to do is fork ActivePerl and then add packages.

Here’s a video that walks you through the steps.

The link you want for the fork mentioned in the video is https://platform.activestate.com/zakg/crustjb/fork

HTH!

Hi Zak,
Thank you for the help, I am working on doing the build now with the needed packages. I have two questions for after I install the build.

  1. Will I be able to add additional packages to the installed build I need them by using the state tool?
  2. Previously, I used the pp.exe from PAR-Packer to create executables based on my Perl scripts. Will I still be able to do that? I didn’t see PAR-Packer in the list of packages? (I did add PAR to my build)

Thanks,
Jim Crust

Jim,
“state packages add” currently supports adding to Python installations, and will support Perl as well in the near future. Existing versions have some issues. The upcoming 5.32 release should be much better.

Par-Packer won’t be in the catalogue for the foreseeable future. There are a couple of problems with it; one of which is that modules wrapped with PP must be run with the exact same version of Perl that the PAR-Packer module was compiled against, and the second of which is that PP isn’t compatible with the current ActivePerl EULA.
Wrapped files can also run afoul of modern security best practices, and be blocked from running, so we don’t recommend wrapped files as a deployment method any longer.

1 Like