Error installing Win32-API on Windows

Tried getting bugzilla up and running on my local machine running Windows 10. The official guide is not written for ActiveState, so I had to do some modification to it. But now i’m stuck, I’m getting the following error when trying to install Win32-API:

Resolving Dependencies /
 x Could not install dependencies
 x Error setting up runtime
 x The Platform failed to resolve the dependencies for this build. These are the last lines of the error message:
…ure|kernel|Linux (*), Feature|kernel|Linux is incompatible with Feature|language/perl|Win32-API.

    And because every version of Platform|CentOS 8, Linux 4.18.0, glibc 2.28 x86 64-bit requires Feature|kernel|Linux
(4.18.0) (1), Platform|CentOS 8, Linux 4.18.0, glibc 2.28 x86 64-bit is incompatible with

    So, because root depends on both Feature|language/perl|Win32-API (*) and Platform|CentOS 8, Linux 4.18.0, glibc 2.28 x86 64-bit (*), version solving failed.

From what I can tell from a quick google search, glibc is not available on Windows. Perl is completely new for me, so any help would be much appreciated.
The machines is only running windows and I got wamp installed. I’m following this guide. instead of ‘ppm install ’ i use ‘state install ’

I am unsure about the glibc but I know we have a windows bugzilla project here: ActiveState perhaps you could fork that to start and upgrade or add only what you need from there?

One of the reasons why you’re having that problem is that the project you copied is multiplatform. You’re probably working in a free account workspace, which does not support multiplatform projects, so you can’t modify any multiplatform projects you have unless you make them single platform projects.

@NicoleSchwartz is correct to recommend the Bugzilla project. It should have the dependencies you need right up front, and not require you to add modules.

Thanks, now the checksetup script find Win32-API module.
There is no module for any database but I can fix that myself.

How can I install an older version of a module?
I installed dbd mysql, and it is showing if I run ‘state packages’.
But the bugzilla don’t recognize it, I assume it’s because It want version 4.001 or later and maybe my version (5.100) is a bit to new.

Did you fork the project?

If yes go to the configuration page, find the desired dependency and click the drop down to pick a new/specific version.

PS this is a package set from early 2023 so it would seen off that it is too new.

as per 3.3. Windows — Bugzilla 5.1 documentation did you do " ActiveState Perl uses a standard Windows Installer. Install, sticking with the defaults, which will install Perl into C:\Perl. It is not recommended to install Perl into a directory containing a space, such as C:\Program Files.

Once the install has completed, log out and log in again to pick up the changes to the PATH environment variable."

Yes, i did. Now Win32-API got installed without issue.
I did find out that I could use the webinterface to change the module version.
But now i got a new issue, but I think that is related to Bugzilla.
When I run i get:

install_driver(mysql) failed: Attempt to reload DBD/ aborted.
Compilation failed in require at (eval 541) line 3, <DATA> chunk 960.

I’m currently running DB::mysql 4.051 (and that is correctly detected).

I asked our developers and got a suggestion

"If it were me, I’d try to write a very small program that loads DBI (which uses DBD-mysql transparently, then connect to the database. If that works, then it’s something in the Bugzilla configuration. If it doesn’t work, it could be the ActiveState runtime, or it could be an incompatibility with the version of MySQL. Check if MySQL is running.I don’t know off the top of my head what that little program would look like; it depends on the MySQL connection information configured in Bugzilla. It’ll look a lot like the first couple of lines of this synopsis though: "

If I copy the synopsis from the link (I added my own credentials and so forth) and run it, i get:
install_driver(mysql) failed: Can't load 'c:/Users/admin/AppData/Local/activestate/cache/e8de52f7/site/lib/auto/DBD/mysql/mysql.dll' for module

I continues and says it cannot find the module (some parts are in Swedish).
I check the path there is cannot find the module, but there dll-file is there. So it should be able to find it.
I tried changing the mysql version, so it would re-download and install the package, but no change.

I’m not sure if the issue here is the same as I had, but when I had ‘attempt to reload Net/ aborted’, the solution (see Attempt to reload Net/ aborted - #7 by onlyonelikeme) was to put the Perl installation exec folder in the Path environment variable instead of the bin folder, i.e. to use C:\Perl\exec\perl.exe rather than C:\Perl\bin\perl.exe. Ultimately, I fixed the issue by keeping the bin folder in Path and adding C:\Perl\usr\bin (to avoid having two Perl tasks, C:\Perl\exec\perl.exe and C:\Perl\bin\perl.exe, running).