Cannot exec state-exec command

I was doing my postgres meson compilation on windoes but there is some error with state-exec command

Run-time dependency tcl found: NO (tried pkgconfig and cmake)
Library tcl found: NO
Has header "tcl.h" with dependency -ltcl: NO (cached)
Run-time dependency pam found: NO (tried pkgconfig and cmake)
Library pam found: NO
Message: disabling optional dependency plperl: perl installation does not have the required modules
Program C:\Users\Imran\AppData\Local\Programs\Python\Python311\python.EXE found: YES (C:\Users\Imran\AppData\Local\Programs\Python\Python311\python.EXE)

It is looking for some file which cannot be found.

state-exec: run failed: cannot create new executor meta: cannot get execmeta from file: ioutil.ReadFile C:\Users\Imran\AppData\Local\ActiveState\StateTool\release\bin\ failed: open C:\Users\Imran\AppData\Local\ActiveState\StateTool\release\bin\ The system cannot find the file specified.
state-exec: Not user serviceable; Please contact support for assistance.

Kinldy help me here.

Thanks Imran

Hey, providing more detail would be helpful - tips are here How do I ask a good question? - Help Center - Stack Overflow

but based on what we have

The tcl.h and plperl messages are not hard errors – they’re messages from the configuration system saying it can’t find optional dependencies and won’t build an optional component.

Unless you really wants plperl support, these should be safe to ignore.

Checking with a different team on the as.meta question

did you run state-exec , this isn’t meant to be ran directly, or did you run state exec ?

also what happened in-between the first thing and the second thing? those two steps don’t logically follow one another