State tool supports deploying tcl with secret like api-key?

Does the State Tool support deploying tcl with secret like api-key? The web page says:

and the word “TCL” clearly didn’t get mentioned on the State Tool page.

(Yes, it would be easy to just try it out, but the installer doesn’t work on my Ubuntu 20.04 with sh: 0: Can't open /dev/fd/63)

2 Likes

Could you elaborate on what you mean by this? Secret functionality is language agnostic, you can use it for just about anything, within reason. See the docs on secrets here:

https://docs.activestate.com/platform/state/start.html#secrets

We’re not able to reproduce this on Ubuntu 20.04, would you mind sharing the full output of the command? Thanks!

2 Likes

After a bit of trial and error one of our devs was able to reproduce your installer issue by running the install command as sudo. We’re investigating possible solutions, but until then please avoid running the install command directly as sudo (if you really wish to install as root you could first enter a root shell and run it from there).

Mind you state tool does not require root to operate.

2 Likes

I just copied what your email newsletter is saying:

I thought so, and I first tried to install and got this message:

Which made me believe that State Tool needs root access. Now I know it doesn’t. Here is how I fixed it, observe that $PATH doesn’t have my .local/bin until I run source .profile that is because user’s bin paths are added by .profile which is not ran in Ubuntu by default.

weiwu@damascus:~$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
weiwu@damascus:~$ source .profile 
weiwu@damascus:~$ echo $PATH
/home/weiwu/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
weiwu@damascus:~$ sh <(curl -q https://platform.activestate.com/dl/cli/install.sh)

ActiveState collects usage statistics and diagnostic data about failures. The 
collected data complies with ActiveState Privacy Policy 
(https://www.activestate.com/company/privacy-policy/) and will be used to 
identify product enhancements, help fix defects, and prevent abuse.

By running the State Tool installer you consent to the Privacy Policy. This is 
required for the State Tool to operate while we are still in beta.

==> Preparing for installation...
==> Installing to /home/weiwu/.local/bin
Continue? [y/N] 
y
==> Determining latest version...
==> Fetching the latest version: 0.11.43-SHA8398a6c8...
==> Verifying checksum...
==> Extracting linux-amd64.tar.gz...
==> Installing to /home/weiwu/.local/bin...
==> State Tool installation complete.
==> You may now start using the 'state' program.

That message is saying that none of the directories on your PATH are writable by your user, so the installer cannot install anywhere that would be usable by you. The way you ended up resolving it is in my opinion the most appropriate solution. :slight_smile: