State Tool Installation failing

My State Tool installation failing on Mac OS X 10.14.6 and Python 3.8

Here is my screen on terminal

Installing the State Tool ..

ActiveState collects usage statistics and diagnostic data about failures. The collected data complies with ActiveState Privacy Policy
( and will be used to identify product enhancements, help fix defects, and prevent abuse.

By running the State Tool installer you consent to the Privacy Policy. This is required for the State Tool to operate while we are still in beta.

==> Preparing for installation...
==> Installing to /Library/Frameworks/Python.framework/Versions/3.8/bin
Continue? [y/N]
==> Determining latest version...

What can I do?
Is it necessary to install another Python version in advance?

Hi subjektives! Grüsse aus die Schweiz!

Thanks for the note and welcome to the forum!

Did the process just hang at Determining latest version...? Was there any other message?

No other messages :frowning:

Do you have a firewall rule that preventing the script from accessing the net?

Maybe, I work behind a proxy.
But the authentication is also in .bash_profile

export JAVA_HOME=$(/usr/libexec/java_home)
export http_proxy="[User]:[Password]@[proxy-Adresse]:3128"
export https_proxy=$http_proxy

Perhaps we can just test if the download part of the install script can run on its own? Can you run the following on your command line?

wget -q -O - \

It should output something like:

    "Version": "0.20.48-SHA22d0888",
    "Sha256v2": "35646bd6460fc0b141c7f97e5b29846526a4794ef41705d8d4eced7c19b06310"

No answer :frowning:

Can you reach the URL with your browser?

Maybe wget isn’t seeing your proxy environment variable?

Do you want to try forcing the proxy settings in a ~/.wgetrc file as per

Thx, i tried this also. No Success.
Same problem:

==> Determining latest version...

Could you reach the URL with your browser?

Also, what error do you get if you the wget command without the -q flag and with the --verbose flag? HTTPS support not compiled in.

Now it’s fine :slight_smile:
After a new installation of wget via homebrew.

1 Like

Oh great! I’ve asked our Product team to think about removing the -q flags for the use of wget (and curl) in the install script. Thanks for letting us know that it worked!