State clean uninstall not working

state clean uninstall is not removing / uninstalling the state command.

PS C:\Windows\system32> state --version ActiveState CLI by ActiveState Software Inc. License BSD 3 Version 0.28.2-SHAbdac00e Revision bdac00ecb11f14510820d58651e9bc85eb4d3741 Branch release Built Mon May 10 2021 23:02:42 +0000 GMT

Screenshot attached. How can I still run the state command after its supposedly successfully removed?

Hi @lemyurek — I’ll check in with the State Tool team to see if it’s a known issue and if so, if there are any workarounds.

hi @lemyurek, is it possible you had multiple State Tools installed? If you run where state it should show you all matching PATH entries.

When you run state clean uninstall it will only uninstall the state tool that ran the command, so if there are multiple state tools on your PATH it won’t uninstall all of them, just the one that was invoked.

If that isn’t the issue, could you try running the command again like this:

SET verbose=true
state clean uninstall

And share the output here. Hopefully the debug log can tell us what might be failing.

I heve the same problem, followed your info and it seems state is still there.

in task manager find a task called state…, end it.
then cmd will allow to uninstall using the command.

I appear to be having a similar problem, after

state clean uninstall

I got an error message about the PATH variable. So I went and deleted all the ActiveState directories in my path.

Then I tried to do a clean reinstall

powershell -Command "& $([scriptblock]::Create((New-Object Net.WebClient).DownloadString('')))"
• Preparing Installer for State Tool Package Manager...√ Done

State Tool Package Manager is already installed. To reinstall use the --force flag.

Not sure how to use the --force flag in the above command.

Ejecuta como Administrador

Still not working. It’s unbelievable ActiveState can’t work out such a basic feature – uninstalling!

1 Like