Perl throws Cwd.c when using debugger in Komodo (9.1 or 12) or in cmd

Running the current prebuild of perl (5.34.1) works fine in the cmd window and in Komodo. When I try running it with Debugging, either way, I get a Cwd.c (mismatched binaries) error.
At first I thought it was a problem with PadWalker and tried dropping down to 1.99 (won’t config) and then 2.0, but it makes no difference.

I was having the same error in Perl-5.28.1 and 5.32.x and that’s why I moved to 5.34.

I’m running a 64-bit version of Windows (v.10.0.19045 Build 19045). Am I just out of luck?

4/30/23 -

perl -e “use Cwd qw(cwd) ;”
Cwd.c: loadable library and perl binaries are mismatched (got handshake key 0000000012200080, needed 0000000012600080)

The default Cwd for the build is 2.21. I tried 2.06 which failed to build. 2.20 also failed to build but this time I looked at the log. I saw only this one error:

collect2.exe: error: ld returned 1 exit status
gmake: *** [Makefile:470: blib\arch\auto\Cwd\Cwd.dll] Error 1

gmake failed: ‘gmake’ exited with value 2 at C:\builds\builder-deps\8dbe1c05-f644-5567-9f49-680aca8a7690\installdir/lib/ActiveState/ line 462.
cp blib\lib\

I’ve built earlier versions of perl on unix boxes, but not in a long time and I don’t know squat about c. But this log entry doesn’t mean much to me, not that I could do anything about it.

Can anyone shed light on this or tell me what else I might try? Debugging w/o a debugger is torture.


Turns out 32 bit Strawberry Perl and 32 bit Komodo IDE 9.1 works.

So glad you found a work around!