Module Win32 fails to build in Windows perl 5.32.1 and 5.32.0

A clean config of perl 5.31.1 (Windows) builds just fine.

Add module Win32 and that module fails to build (although the perl build succeeds).

From what I see in the log, it looks like Win32.c fails to compile.

(Sure would be nice if you could copy the text of the log!)

Hey @jgpuckering,

Thanks! I’ll pass the note on Win32 not building to the dev team.

You should be able to click on a log to give it focus, then select all. However, I agree that a button certainly would be easier and more intuitive. :smiley:


Yes, turns out clicking and selecting worked. Not sure why it didn’t when I tried it before – but then, I might have mindlessly done a Ctl-A and Shift-Insert because I thought I was in console context. (It does LOOK like a console, after all! And the mind is a funny thing…present it with a new context and it’s remarkable how quickly it adapts to the context!)

Anyway, thanks for that.

I neglected to mention that the Win32 problem popped up when I added the Database bundle. I tried adding it again around 10:00 pm tonight and it still blows up compiling Win32.c. Here are the relevant log entries:

Running [gmake]…
Win32.o:Win32.c:(.text+0x4243): undefined reference to `CreateEnvironmentBlock’

Win32.o:Win32.c:(.text+0x4301): undefined reference to `DestroyEnvironmentBlock’

Win32.o:Win32.c:(.text+0x4315): undefined reference to `DestroyEnvironmentBlock’

collect2.exe: error: ld returned 1 exit status
gmake: *** [Makefile:472: blib\arch\auto\Win32\Win32.dll] Error 1

Ha! My personal favourite is using Vim commands in other apps without thinking. :slight_smile:

It looks like the team has started work on the issue - however, I can’t promise any timeframe for resolution. We’ll update as we get more info.