Perl-5.32.0-Windows fails with Missing artifacts from AWS

Getting 403 errors from the server on artifacts:

x Could not update runtime installation
x Not all artifacts could be installed:
Failed to install artifact Clone (5b71e26e-2138-5350-a556-a0f4bdd60891). Error received: Could not download artifact s3://as-builds/production/language/perl/Clone/0.45/3/5b71e26e-2138-5350-a556-a0f4bdd60891/artifact.tar.gz: Download!F(MISSING)20220323%!F(MISSING)us-east-1%!F(MISSING)s3%!F(MISSING)aws4_request&X-Amz-Date=20220323T225518Z&X-Amz-Expires=21600&X-Amz-SignedHeaders=host&X-Amz-Signature=cc7a55db4f49d54369ac8a5e4f82cde868a4e78422c8f4d57ac0b6a025a0421f failed: Invalid status code: 403. :: Invalid status code: 403
many more here.
Failed to install artifact XML-LibXSLT (fd7ee56e-d429-50c0-8708-afadcc0f9f64). Error received: Could not download artifact s3://as-builds/production/language/perl/XML-LibXSLT/1.99/6/fd7ee56e-d429-50c0-8708-afadcc0f9f64/artifact.tar.gz: Download!F(MISSING)20220323%!F(MISSING)us-east-1%!F(MISSING)s3%!F(MISSING)aws4_request&X-Amz-Date=20220323T230019Z&X-Amz-Expires=21600&X-Amz-SignedHeaders=host&X-Amz-Signature=e3922fa7a7e065c4b80eb4e6f77a9f4d1e6aa5520576aec32135e74b883c350d failed: Invalid status code: 403. :: Invalid status code: 403

Tried to continue multiple times does not seem to be progressing:

Do we have to wait for the artifacts to be uploaded to AWS before installation is available?

As I keep on trying to load, it looks like the list of Artifacts with status 403 are getting smaller.

Possibility, it takes time for AS to upload artifacts to AWS so they are available. Is this what is happening?



Keep trying again and again. Finally, left with only one artifact missing:

Installing ⠦ 0/1 [--------------------------------------] 0 %

Something Went Wrong
x Could not update runtime installation
x Not all artifacts could be installed:
Failed to install artifact postgresql (563501fa-4b76-5ae4-b458-3d2f1b80b398). Error received: Could not download artifact s3://as-builds/production/shared/postgresql/12.6.0/1/563501fa-4b76-5ae4-b458-3d2f1b80b398/artifact.tar.gz: Download!F(MISSING)20220324%!F(MISSING)us-east-1%!F(MISSING)s3%!F(MISSING)aws4_request&X-Amz-Date=20220324T181359Z&X-Amz-Expires=21600&X-Amz-SignedHeaders=host&X-Amz-Signature=0615bc82d9b4669b88dd17a6b1b4e05b894119535014936121c76dc1ce91fc50 failed: Invalid status code: 403. :: Invalid status code: 403

Need More Help?
• Run → state activate --help for general help
• Check the Build Log to find out more: C:\Users\wz0895\AppData\Local\Temp\build-log-2271217932
• Ask For Help → State Tool - ActiveState Community
Running provided command failed, error returned: exit status 1

postgresql - of course, this is the reason I needed perl for in the first place.

My old version of perl cannot talk with postgres due to the following error:


DBID: postgres@localhost/Blue!Moon7
install_driver(Pg) failed: Can’t locate DBD/ in @INC (@INC contains: c:/Perl/site/lib c:/Perl/lib .) at (eval 5) line 3.
Perhaps the DBD::Pg perl module hasn’t been fully installed,
or perhaps the capitalisation of ‘Pg’ isn’t right.
Available drivers: CSV, DBM, ExampleP, File, Gofer, ODBC, Oracle, Proxy, SQLite, Sponge, XBase, mysql.
at line 17


DBID: postgres@localhost/Blue!Moon7
DBI connect(’’,‘postgres@localhost’,…) failed: SCRAM authentication requires libpq version 10 or above at line 17.
Can’t connect to database: SCRAM authentication requires libpq version 10 or above

c:\Users\wz0895\Desktop\perl\FORD>powershell -Command “& $([scriptblock]::Create((New-Object Net.WebClient).DownloadString(‘’)))”
Exception calling “DownloadString” with “1” argument(s): “The remote server returned an error: (403) Forbidden.”
At line:1 char:5

  • & $([scriptblock]::Create((New-Object Net.WebClient).DownloadString(’ …
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : NotSpecified: (:slight_smile: , MethodInvocationException
    • FullyQualifiedErrorId : WebException

The expression after ‘&’ in a pipeline element produced an object that was not valid. It must result in a command name, a script block, or a CommandInfo object.
At line:1 char:3

  • & $([scriptblock]::Create((New-Object Net.WebClient).DownloadString(’ …
  • + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
    + FullyQualifiedErrorId : BadExpression

Hi Jodyman,

Can you let me know what state tool command you are trying to run, can you copy that here for me?



Also I did a “state activate jodyman/Perl-5.32.0-Windows” and it worked great.

Get this but trying your way: ( says it’s installing Update )

C:\WINDOWS\system32>state activate jodyman/Perl-5.32.0-Windows
Sorry! This is a transitional tool that should have been replaced during the last update. If you see this message, something must have gone wrong. Re-trying to update now. If this keeps happening please re-install the State Tool as described here: Install the State Tool: ActiveState Platform's CLI tool

Yeah there have been some significant state tool changes of late. I recommend a full reinstall and give it a whirl. Send any issues you have.