Help! I deleted my activestate.yaml file :(

I am really struggling to get a Perl installation going with Tk.
A few years ago I used to use ppm and now I see the whole thing is different.
The state tool and the activatestate.com virtual environment thing.
I’m an experienced programmer but am really confused now.
Even experts need a step by step foolproof tutorial to get things going…

I have been trying this and trying that and had some success.
But in my valiant efforts I tried to clear out the cruft and ended up deleting the activestate.yaml file and now nothing will work at all.

What can I do?

Hey jonbj! Thanks for checking out the new state tool experience. So, couple questions:

  • What version of Perl are you on?
  • What version of Tk are you trying to install?
  • What project are you working with on the platform?

One thing to try first, is inside the project folder, try ‘state pull’ to get the latest version of the yaml – but if that doesn’t work, let us know the above answers and we’ll dig a bit deeper. The solution depends on which version you’re working with.

1 Like

Thank you, Pete.
I tried ‘state pull’ - same error that says “Your activated environment appears to have been corrupted because the activestate.yaml file cannot be found anywhere.”

It also says that I could “deactivate your activated state”. I don’t know how to do that.

Perl 5.28.1
Tk 804.034
The project is TheCenter.
My userid is jonbj
There are several other projects on the account that show my flailing. I presume they can be deleted.,

It does seem that your new system has several advantages.
But better documentation and a step-by-step guide for Idiots (old Perl hackers like me :slight_smile: ) would be helpful.

Hi jonbj,

If you still know your project name, you can simply run state activate jonbj/TheCenter --path <the/path/to/your/project>. After that your activestate.yaml file should be recovered.

Thank you, MDrohman.
That did work and I am able to create a simple Tk program.
Next question… To add more modules to the system I tried this:
I chose Configuration and added the useful module List::Utils.
And comitted the change.
Then I said “build”. The build took a while but did complete.
I went back to the command line and did 'state pull. It seemed to update with the latest commit.but when I say “perldoc List::Utils” it is not found.

What do I need to do?
Thank you.
Jon

I said “state history” and I see this:

[jonbj/TheCenter] c:\Users\jonbj\TheCenter>state history
2020/11/26 00:20:41 Rollbar error: empty token
╔═════════════════════════╗
║ Viewing Project History ║
╚═════════════════════════╝
Commit Author Date Commit Message Changes

────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
6a432271 jonbj 26 Nov 2020 07:1 - added List-Utils
1
96b42ac0 jonbj 19 Nov 2020 22:0 - added Tk
9 - added Win32-OLE
b435495b jonbj 19 Nov 2020 22:0 Initialize project via the State - added perl 5.28.1
5 Tool - added Platform

It says List-Utils is there but it is NOT.

Ah…
In addition to ‘state pull’
I need to type ‘exit’ to leave the current build.
And then ‘state activate’ to actually download the latest.

This whole sequence of actions should be put in a step by step document for newbies.

Now I can proceed with my project… .

Glad you got it working! You should be able to state pull to get updates from any changes you make on the platform so we’ll take a look at that and see if we can reproduce the issue where state pull didn’t pull down your latest changes from the platform since you should be able to just state pull to refresh your project without having to re-activate it. Thanks for sticking with it!