GDGraph dependency issue

Can someone please help out to solve the GDGraph dependency issue?
Thank you

Unable to Resolve Dependencies!

Here’s what happened…

Because no versions of Feature|language/perl|GDGraph match !=1.54 and Feature|language/perl|GDGraph (1.54) is provided by Ingredient|language/perl|GDGraph (1.54), every version of Feature|language/perl|GDGraph requires Ingredient|language/perl|GDGraph (1.54). And because Ingredient|language/perl|GDGraph (1.54) depends on Feature|language/perl|GD (>=1.18), every version of Feature|language/perl|GDGraph requires Feature|language/perl|GD (>=1.18). And because no versions of Feature|language/perl|GD match >=1.18,<2.67 || >2.67 and Feature|language/perl|GD (2.67) is provided by Ingredient|language/perl|GD (2.67), every version of Feature|language/perl|GDGraph requires Ingredient|language/perl|GD (2.67). And because Ingredient|language/perl|GD (2.67) depends on Feature|shared|libgd (>=2.2.4) and no versions of Feature|shared|libgd match >=2.2.4,<2.2.5 || >2.2.5, every version of Feature|language/perl|GDGraph requires Feature|shared|libgd (2.2.5). And because Feature|shared|libgd (2.2.5) requires Ingredient|shared|libgd (2.2.5) which depends on Feature|builder|camel (>=0), every version of Feature|language/perl|GDGraph requires Feature|builder|camel (>=0). And because Ingredient|language|perl (5.32.0) depends on not Feature|builder|camel () and Feature|language|perl (5.32.0) is provided by Ingredient|language|perl (5.32.0), Feature|language/perl|GDGraph is incompatible with Feature|language|perl (5.32.0). So, because root depends on both Feature|language/perl|GDGraph () and Feature|language|perl (5.32.0), version solving failed.

What happens next?

Until these errors are resolved, we cannot attempt a build. If you recognize any of the packages in the error messages, try removing them or requesting a different version.

Hey @bakiperl!

Thanks for writing!

What is the project that you are having problems with?

Did you upgrade the version of Perl used for this particular project? Say from 5.28.1 to 5.32?


Hey Zak,
The issue is happening with Perl-5.32.0-windows project. I also tried to add the GD library and I get similar error message.
on the other hand, I was able to built the package in the Perl-5.28.1 project without any issues.
Thank you.

Hey @bakiperl!

Thanks for the extra details!

This is definitely one for our development team to take a look at. I’ve passed it on to them and will update as soon as I get a response (which may not be so fast at the moment.)