Cannot install the ActiveTcl successfully

I just Copy and paste the command into my Command Prompt and hit Enter to install it,but it always said that something went wrong.

If you have time ,please help me , Thank you so much!

You have already installed The State Tool, and something else as your default project.

Once you have the State Tool installed, you can’t use that cut and paste command. The command reference manual is found here:
You probably want to be doing a “state activate”.

Or, you might be wanting to download the exe or msi installer, and install it from there. Look for the Downloads tab from your account.

Hi All, Also first time user but dug a bit deeper. Found that the unzipping of the bundle in C:\Users\cs69\AppData\Local\ActiveState\cache\ff89621e_runtime_temp doesn’t work. The file is faulty. Double clicking on the file makes Windows come up and say the file is faulty. Using 7Zip for extraction gets the following message:

Can not open the file as [zip] archive
The file is open as [gzip] archive

The file then decompresses and promptly gets replaced when you try to activate again. Bit of a dead end really.

Can you fix it soon please!

From the build log:

To increase the verbosity of these log files use the ACTIVESTATE_CLI_BUILD_VERBOSE=true environment variable
[bundle (1cd4b539-63da-5d8d-87e2-38b941008db1)] Build completed successfully
== Installation started: (0/1) ==
[bundle (1cd4b539-63da-5d8d-87e2-38b941008db1)] Downloading started
[bundle (1cd4b539-63da-5d8d-87e2-38b941008db1)] Downloading completed SUCCESSFULLY
[bundle (1cd4b539-63da-5d8d-87e2-38b941008db1)] Unpacking started
[bundle (1cd4b539-63da-5d8d-87e2-38b941008db1)] Unpacking completed with FAILURE: Could not unpack artifact C:\Users\cs69\AppData\Local\activestate\cache\ff89621e_runtime_temp\

I am having the same problem and your explanation is not enough to solve it! there is no way to download the exe in the download tab. You have to do it copy-paste and it apparently does not work. I am not sure if I already installed the state tool. Please help us in a more clear way!!


I’ve been looking for the exe as well but I don’t think they publish it anymore. I saw something on this site noting a policy change regarding the exe’s back in August (I think) but I can’t find that page again. As for fixing your problem, I can’t! That’s what my post is about. The ZIP file at their end needs fixing, and until they fix the file I don’t think there’s a thing we can do. I’m stuck too mate … Sorry! I could easily start a rant because I’m pretty annoyed by this whole experience. I’ve been forced here by a third party because they’ve distributed their interface as a TCL file expecting you can just download an exe and be up and running. Apparently not so and now this is just a huge waste of my time and I’ve had to sign up to this site that I don’t really want anything to with… So just please go back to making exe’s and keep people like me at arm’s length!!! At least make sure what you put up actually works (bare minimum).

I didn’t mean to you. I was talking to support guys.

Oh Sorry. Well I guess we’re on the same page then. I wonder how long it will take?
Gave me a chance for a rant anyway!

I can’t believe this is true. TCL is not loading!!
Same problem here. No exe. And same unzip problem. Hopefully a solution is near.
How can we upvote the problem so the community knows this is critical!

I tried running “state activate --path C:\Users\Incise\adij\ActiveTcl-8.6”, but getting the same error as described already in detail by other. Exact same issue.

A Rule of Thumb:
If we offer a downloadable exe or msi format installer, don’t use the State Tool.
This advice might change over time, but there are two separate build systems. One generates State Tool installable builds, and the other generates exe or msi format downloads. Installers from one build system don’t necessarily work with the other process.

ActiveTcl 8.7 and ActiveTcl 9.0 will be built on the system that generates builds for use with the State Tool.

Hey there ActiveState-Support

First off, really disappointed in your response above. I’ve tried again to get this working, but no. I’ll do the following in point form to make it easier to address and respond to each issue in turn. This will be a guide as to how well you read and consider this feedback.

  • Do you realise that the ZIP file that is downloaded for Windows is only 2k? (So clearly invalid)

  • There is a ‘Download Builds’ tab with no ability to download either EXE or MSI

  • After forking the project, there is no option to rebuild the project under my dashboard to try and generate a valid zip file

  • Maybe things aren’t working the way you expect on your webpage. You say:

If we offer a downloadable exe or msi format installer

You don’t offer exe or msi format installers for Tcl, so we have to use the state tool.

You also say:

there are two separate build systems

No there isn’t, there isn’t even one build system!

Please fix the zip file issue so I can get working with the software I require, then get the EXE’s and msi’s up and running again.



Hi Chuck,

I have the same problem as you too. I solved it by downloading the exe
from the BAWT frammework Downloads | BAWT

Hey @chuckyrs71 @danilo-colucci @adij @bariskasapoglu @chejiayu – the issue you’ve run into here is a result of a change we made elsewhere on the platform that inadvertently impacted Tcl builds – we’re working to address this and reverse the change so that you’ll have access to the installers again. Thanks for your patience. We’ll update this thread when the fix has been deployed.

“Do you realise that the ZIP file that is downloaded for Windows is only 2k?”
Yes. That’s because you’re not downloading the installer for Tcl. You’re downloading a zipfile bootstrap installer, which only contains The State Tool and a set of instructions (which don’t work with Tcl 8.6) for downloading the rest of the components it needs from The Platform. In order to work with a bootstrap installer like this one, the build needs to be created on the build system that matches, and ActiveTcl 8.6 is not from that build system.
There isn’t a zip file installer for ActiveTcl, and has never been a zipfile installer; not even all the way back to Tcl 8.3.

The Platform is a Build System As A Service. There are more than two different build systems counting the ones that are not yet in production use, but users do not have access to any of the controls that instruct The Platform on which of the systems to build with.

“Maybe things aren’t working the way you expect on your webpage.”
That’s indeed the case. We have a bug. A feature that isn’t supposed to affect Tcl 8.6 is actually affecting Tcl 8.6, and as a result, the web site is hiding the Exe and MSI format installers. They’re there, and we’re working on a fix to get the website to not apply the feature to Tcl 8.6.

Great, thanks for the information. Hope you can get that work around up and running soon.

Just to clarify the download thing a bit. I’m using ‘state activate chuckyrs71/ActiveTcl-8.6’. The file ‘’ downloads to C:\Users\blah\AppData\Local\ActiveState\cache\ff89621e_runtime_temp. is a 2k file that just doesn’t work. This is the artifact bundle that fails to install because it is an invalid zip file. This is failure from the build log that I posted earlier.

Is this something you can fix for now? Or shed some light on why it isn’t downloading properly?

Thanks for your help with this, it seems I have turned up at a bad time…


Hey Pete, I saw this after my latest reply. Thanks for all the info, like I said, just turned up at a bad time. I’m sure you’ll let us know when you’re set to go.

Can’t really fix that one unfortunately. Not quickly anyway. “State activate” needs to have a project that’s compatible, and Tcl 8.6 projects, like chuckyrs71/ActiveTcl-8.6, are not supported by the State commands because they’re Tcl, The State Tool just does not understand what it needs to do with Tcl. It knows Python and Perl, and Ruby soon, but Tcl support will probably not be available at the 8.6 version.
The bug fix for the web site is considerably easier to fix that than, so you’ll see the links for MSI and EXE files back quickly.

Awesome, that’s everything we need to know. Thanks and hope the bugs iron out quickly for you. I’ll leave you in peace now. Please just let us know when we’re right to go.

Ok. I can see the MSI and EXE downloads again from a normal user ID, but only for Tcl 8.6 projects, as it should be. You’ll need a fresh browser tab. If an older version of the dashboard is still loaded, you’ll see some other scary looking error messages.

Thank you! Loaded - Running - No Problems!