Build Status: tk 804.028 Success -> Can't locate in @INC

I tried the *.exe and the *msi package twice.
(ActivePerl- *.msi)
I also deleted Math:BigInt,
After installing:
-> Can’t locate in @INC
-> c:\Perl64\lib\Math\BigInt is installed



Sorry about your problem, but we’ll try to help resolve it. Can you clarify the issue a bit more, do you run into this problem (not locating Tk) after trying to remove Math:BigInt, or just in the regular Perl 5.28 install?

I looked into your project, and I see the issue. There are two modules. One is called “Tk”. That’s the one with the actual code and that’s the one you want. The other is called “tk”, and it looks like a collection of curated demos for the Tk module. If you swap “tk” for “Tk”, you should get what you’re looking for.

As for Math-BigInt, you won’t be able to remove it. There are some modules that are “core” modules. The definition of “what is Perl” is set at each major version number, and a core module is one that is considered an essential characteristic of Perl.

You can remove any version number override on core modules, but you’ll still get the version number that the definition of Perl for that release specifies.

Thank you, it was my fault. It must be Tk, but because I found tk, I didn’t think further. I choose BitInt for a remove test, which I don’t use.

Thanks … WH