Build Error: Net-ARP 1.0.11 for Perl 5.28.1 on Windows

OK so I’ve been trying to get a perl installation with Net::ARP. No matter what I do it fails. I’ve tried starting with a basic perl distribution then attempted to install from CPAN. Still No luck. Even with the Build constructor here on activestate, the packages fail to build. What’s with the ARP library that it won’t install?

Looking for help with this package that is failing to build in my project.

Runtime Details

  • ActiveState
  • Language - perl 5.28.1
  • Platform - Windows

Failing Packages

  • Net-ARP 1.0.11


  • Build failures: module Net-Arping, module Net-ARP, module Net-Libdnet

FYI, I’m running Windows 10

Offhand, I would suspect it’s because Net::ARP only works on Linux or BSD. The CPAN test history shows that nobody has ever reported a successful test on any O/S that isn’t Linux.;maxver=1

That makes sense. Kind of. Net::ARP wont install on iOS either. In case you didnt know, ios is based on Alpine Linux. Also it still wont properly build when I attempt a custom package to be built on the activestate server.