Build Error: Astro-FITS-CFITSIO 1.15 for Perl 5.28.1 on Windows

Looking for help with this package that is failing to build in my project.
According to the author’s page for Astro::FITS::CFITSIO, you need to include an additional library for the underlying CFITSIO software.

Astro::FITS::CFITSIO

A Perl interface to William Pence’s CFITSIO subroutine library

  • (30 June 2010) Astro::FITS::CFITSIO 1.15 Perl module and patches, if any. NOTE: version 3.48 of the CFITSIO library is required.
  • CFITSIO Home Page

Is there any way to get the source for cfitsio (or provide the library) to build with this package? If not does that mean I can’t use active state perl and must do a full build on my own? Any tips are appreciated, thanks!

Runtime Details

Failing Packages

  • Astro-FITS-CFITSIO 1.15

Reasons

  • Build failures: module Astro-FITS-CFITSIO, module PerlMagick, module Astro-FITS-CFITSIO-Simple

Hi @alightner - Thanks for the note!

I’ll get the build team to check out the issue and then get back to you.

Cheers!

Excellent, thank you for looking into this! Reading fits header data via perl would be sweet!