Undefined subroutine &ActiveState::Build::Step::Role::BuildKomodoBootstrapper::create_code_signing_cert

This project has failed to build.

ActivePerl-5.28-Greedy-Package-Trial - lemorin - Builds - ActiveState Platform https://platform.activestate.com/lemorin/ActivePerl-5.28-Greedy-Package-Trial/distributions?platformID=78977bc8-0f32-519d-80f3-9043f059398c

Download Builds
Build Status “FAIL”

Reason: The build encountered an unexpected error. Please consult the build log for more details.

  • Build failures: WinInstaller
  • Undefined subroutine &ActiveState::Build::Step::Role::BuildKomodoBootstrapper::create_code_signing_cert called at C:/build/camel/lib/ActiveState/Build/Step/Role/BuildKomodoBootstrapper.pm line 19.

Please fix this failure.
Thank you.

2 Likes

Hi @lemorin,

Thanks for letting us know! I’ll pass it on to the dev team.

Cheers!

1 Like

This installer issue has been corrected, I have restarted your build to pick up the fix.

1 Like

This failure is gone, but I couldn’t build because I got 3 other failures instead.

Convert-NLS_DATE_FORMAT
DateTime-Format-Pg
Protocol-WebSocket

Thank you.

Try adding them back, Convert-NLS_DATE was failing due to a failure with : Module::Build::Tiny that was also fixed this morning. (If you get an immediate failure the build is reverting to cache)

Convert-NLS_DATE_FORMAT
DateTime-Format-Pg
Protocol-WebSocket

2 Likes

I confirmed that I can build by adding the following 3 packages.
Thank you very much.

Convert-NLS_DATE_FORMAT
DateTime-Format-Pg
Protocol-WebSocket

1 Like