Problems installing Activestate Perl on Win 10 x64

I made a build including all packages I will need. Got the link, then did
C:\Users\sale>powershell -Command "& $([scriptblock]::Create((New-Object Net.WebClient).DownloadString(‘’))) -activate-default sale21/Perl-5.34.0-Windows1"
• Preparing Installer for State Tool Package Manager…√ Done

State Tool Package Manager is already installed. To reinstall use the --force flag.

Running state activate --default sale21/Perl-5.34.0-Windows1

Something Went Wrong
x Failed to check for update

Need More Help?
• Visit the Forum → State Tool - ActiveState Community
Could not activate sale21/Perl-5.34.0-Windows1, error returned: exit status 1

So I tried again with the --force flag and again no luck:

C:\Users\sale>powershell -Command “& $([scriptblock]::Create((New-Object Net.WebClient).DownloadString(‘’))) -activate-default sale21/Perl-5.34.0-Windows1” --force
• Preparing Installer for State Tool Package Manager…√ Done

█ Installing State Tool Package Manager

The State Tool lets you install and manage your language runtimes.

ActiveState collects usage statistics and diagnostic data about failures.
By using the State Tool Package Manager you agree to the terms of ActiveState’s Privacy Policy,
available at: Privacy Policy/Statement - ActiveState

Could not retrieve install package information

Any ideas?

Hey @sale21 - I’ll check in with the State Tool team and get back to you!

Hi @sale21, I wonder if you might have a firewall or some other type of network filter (eg. a proxy) configured that might be interfering. Could you run set VERBOSE=true in your command prompt and then run the one liner again? Then share the FULL output.

This should hopefully give us more information about why it’s unable to retrieve the package information.

I’m having the very same issue: “Could not retrieve install package information”.

There is a proxy in place (as there normally would be) but all https otherwise does work ok. Please see attached a snippet of the log with verbose set to true.

hey I met the exact same error and tried to open the verbose mode. but still don’t know where got wrong. any solution?