How do I just DOWNLOAD PERL

I don’t want to create a project on I-Can’t-Believe-It’s-Not-Github.

What the tarnation is this even

5 Likes

The ActiveState Platform is a Build-system-as-a-service, or another way of thinking of it; a way to treat your Perl/Python/Tcl/Ruby language as software, and manage it the same way you would manage your code repository. Static downloads don’t do that.

ActiveState Perl is now for professional developers only. The philosophy is now “Goodbye and good riddance” to those of us who have used Perl at home for decades to produce reports.

7 Likes

For real man. I just wasted 2 hours of my time trying to figure out how to just download it like previous versions. Never coming back here again and I’m recommending to my vendors to remove the Active State recommendation from their documentation.

3 Likes

Go to strawberryperl.com and download the MSI.

6 Likes

This website owner is holy stupid.

3 Likes

Right I’ve been using active state for years. Just trying to install it to a new machine. I ran the state utility and it did something but I can’t find perl anywhere.

Thank you for this. I downloaded it and it ran the scripts I needed no additional modules necessary in 5 min.

Will I run a random installer shell script? Probably not.

Hi ActiveState. You guys have completely, utterly, totally lost the plot.

I have used ActivePerl for years and years and due to a now-ubiquitous Net::SSLeay crash I had to update beyond 5.24. I cannot believe what I found here.

I am a professional developer who has worked on projects ranging from 1 to 3000 people in multiple languages. I could NEVER imagine EVER wanting anything as convoluted, over-complicated, and poorly documented as whatever it is you have done to ActivePerl with your new “state tool.”

Like an erstwhile few who have come in the decades before you, you have managed to create the holy grail: “complicated non-solutions to simple non-problems.”

Like everyone else here, I tried to follow your bizarre PowerShell instruction, which ran an absurd ASCII graphics dance on my console, and, with all deliberate speed, set out to create the structure of planning to plan to consider the option of maybe creating a framework to one day, virtually or in actual fact, but with mutual buy-in of many in the community and with continuous monitoring by outside entities and of course subject to properly approved licensure, go ahead and put together an exploratory committee to discuss the possibility of actually installing a Perl binary. But no such binary got installed. And my cmd.exe window was left in a corrupt state where every other command I type got ignored.

And now after wasting 60+ minutes scanning responses by all the other understandably confused customers on this forum, I see that I have to type the completely obvious:

state deploy myusername\Perl-5.36.0-Windows

which was NOT actually documented anywhere in the portal or Install screen, even though it is CRITICAL to the OBVIOUS goal of 100% of the people who clicked the portal to install ActivePerl!!!

And soon I quickly discovered that many of the modules I depend on and have installed from ActiveState (in one simple command line and 10 seconds of time) for years and years are no longer available at all, or fail to build. Other modules built, but took more than 10-100 times longer to install than with ppm.

I have been shaking my head non-stop for 90 minutes. I am flabbergasted by the insanity of all this.

I cannot imagine anyone who is so obsessed by process that they would actually design or use use a system like this, even for very large teams. Yes, configuration management and supply chain integrity are problems that various teams have, but this is clearly not the solution. This is like trying to solve the problem that my car occasionally stalls by requiring me to spec out and then assemble my entire vehicle from scratch every time I want to go get some pizza.

I don’t have any questions…I just needed to read the other people’s posts here and write my own to confirm that, in fact, it is ActiveState who has gone insane and the rest of us are all OK.

Strawberry it is…

2 Likes

I love your reply. I switched to Strawberry as well.

Activestate is out for now. No transparency, full with errors in installation procedure.
There are better solutions.

1 Like