HELP! Cannot move/resize/restore IDE in Windows10. fullscreen only

All of a sudden, i can no longer move/resize Komodo IDE in Windows 10. It is stuck on screen1 fullscreen. Cannot resize or restore. Cannot move to 2nd external monitor. I can somehow grab the corners of the window and drag to resize. But nowhere can I grab the title bar to move the window/frame. Its just plain stuck.

IDE function appears ok. (code edits etc). Full Windows controls Worked just fine yesterday. Today its BROKE!
I event uninstalled and re-installed it. Same issue.
Windows 10. 64bit.
Komodo IDE, version 12.0.1, build 91869, platform win32-x86.
Built on Mon Feb 10 18:14:23 2020.

SOLVED! (kind of).
Turns out theres a “Full Screen” checkbox in the Top/right menu for options. This was selected. By clicking it. The fullscreen mode was turned off. However, (bug) the checkbox remains selected in the menu, even after disabling.
No idea how this was selected in the first place. I NEVER clicked on that menu item so this still partially remains a mystery.

Thanks for the report @mdoggm1 - I’ll let the Komodo team know!

Hi @mdoggm1, you likely pressed F11 without realizing it which enables fullscreen mode.

  • Carey

Oh. Thats entirely possible i suppose. But it is odd that setting survived a complete uninstall/re-install of Komodo.

Morning @mdoggm1, unless you manually deleted the Komodo Profile folder then your preferences persist even if you uninstall Komodo. That would include enabling that preference.

Apologies for the confusion by the way, I’m sure that was frustrating!