Can't import packages for Python

When I try to import packages for Python via the “Import package” dialog, the “Import” button would never change to be clickable, and also on the console, I can see those errors:

elmApp.js:4037 Uncaught TypeError: Cannot read properties of undefined (reading ‘childNodes’)
at xr (elmApp.js:4037:27)
at xr (elmApp.js:4045:8)
at xr (elmApp.js:4045:8)
at xr (elmApp.js:4045:8)
at xr (elmApp.js:4031:10)
at vr (elmApp.js:3961:2)
at xr (elmApp.js:3977:4)
at xr (elmApp.js:4045:8)
at xr (elmApp.js:4045:8)
at xr (elmApp.js:4031:10)

Hi mrVragec,

Interesting, I’m trying to figure out how to reproduce here.
Can you supply us with the file you are trying to import? I presume a requirements.txt file or similar. If you’re just adding individual packages you can use the Add Packages dialog on the Configuration page.
Also what browser/OS are you using?

Cheers,

-JR

Hi JeffR,

yes, without a problem, I can deliver you all the details. :slight_smile:
In my case, there is no file, I just copy the content of the requirements.txt file and paste the content to the “Import Packages” dialog (as the “Choose File” doesn’t open any dialog or anything anymore today :frowning: ) as there are too many packages to add them individually.
And after that, I can see the uncaught exception on the console :slight_smile:
I’m using macOS Monterey V12.5.1 with Google Chrome 105.0.5195.125. I also tried on Brave Browser, but the behavior was the same.
Just to mention, when I created my first project everything seem to work fine, and then I remove the project, so there were no projects related to my username and created a new one (so as to have exactly one project). After that, I have this issue. I also tried with a new user, as I thought it was related to the number of created projects under the user but that was not the case.

Best regards,
Simon