Cannot install DBD-DB2

I have tried everything … installing from the build; install with the state tool; manually with the MakeFile; and it always fails. error message:

x Could not install dependencies
x The Platform failed to resolve the dependencies for this build. \nBecause root depends on every version of Feature|language/perl|dbd-db2 which doesn’t match any versions, version solving failed.
x dbd-db2 is unavailable

This is my DB2 license info:
Product name: “DB2 Connect Application Server Advanced Edition”
License type: “Client Device”
Expiry date: “Permanent”
Product identifier: “db2consv”
Version information: “11.5”

I also created an environment variable named DB2_HOME and set path to db2 folder

Still won’t work … anyone, please help! thank you

Hi mrutkunas,

This is not currently building on our platform as it looks like it needs a C connector library and at least one other dependency. We’ll take a look.

Also you had a project in your account that was stuck in the build phase, which we have rebuilt for you.



Thank you Jeff … i appreciate you taking a look into this…
I just used a build that didn’t have the dbd-db2 pkg and just tried doing this via command prompt with the state install.

I’m thinking it has to do with the DBD-DB2 version with my installed DB2 … since the error states :“version solving failed”

So based on my db2 license, I am not sure what version I would need for this to run.

Again … thank you for taking a look … any thoughts/ideas are greatly welcome!

Pretty sure it’s not a license issue, it is not building on our platform as yet so it wouldn’t even get that far… Here is a project with just that package: ActiveState

Unfortunately, we have a considerable queue of items to address, so there is no ETA on to when we could look at this. The state tool also uses teh platform to solve and build all your project dependencies, so it won’t work either until the platform has a way to build it, and it looks like it requires a build engineer to look at it.



Thank you Jeff for your attention in this manner.

It seems like this has been a problem with the DBD::DB2 module for awhile now.

I contacted IBM to see on their side what they say and they said we shouldn’t have any issue.

Do you know if any binaries are needed ? Or .dll files for windows? I’ll reach out to IBM as well, but I wanted to see if you can find anything out on the ActiveState perl side.