Build Error: PPIx-Utilities 1.001000 for Perl 5.28.1 on Windows

Looking for help with this package that is failing to build in my project.

Runtime Details

  • ActiveState
  • Language - perl 5.28.1
  • Platform - Windows

Failing Packages

  • PPIx-Utilities 1.001000

Reasons

  • Build failures: module version, module DateTime-Set, module PPIx-Utilities, module Perl-Critic

Hi @roojSuparna!

It looks like you fixed the issue by removing ActiveState-PerlCritic. Is that right?

Cheers!
–zak

Start with a fresh fork from the most recent 5.28.1 instead.

The old version of 5.26 that you started with has an obsolete recipe. Many of those ingredients are toxic to The Platform builder. You could probably get past the problem by just removing PPM and PPM repositories from the list, but there are other updates you would need as well. It will be faster to toss this one out and start fresh.

1 Like