ActiveState Perl, read errors, STDIN? debugger and Dumper not working. HELP!

I have previously used Strawberry and an old ActiveState (5.2x) with no problems. I’ve loaded ActiveState Perl on Windows 11 and am getting errors like this:
> perl -d “”
Can’t figure out your console, using stdin: No such file or directory

When I run without the debugger, it gets to the point where it wants to instantiate XLXS parser and fails:
my $parser = Spreadsheet::ParseXLSX->new();
Can’t call method “read” on an undefined value at c:/Users/(my account)/AppData/Local/activestate/cache/0b12db88/site/lib/Spreadsheet/ line 86, line 3.

I am stumped. Weirdly, the first time I ran it, it worked. But every subsequent time, it fails with this same error.

EDITED TO ADD: Nothing is working! Data::Dumper prints nothing, sometimes print works, other times it doesn’t. I’m dealing with a program that has been running for years and now I’m trying to run it with a newly installed ActiveState and NOTHING is working. The debugger doesn’t work either.

After searching online for any hints as to what’s missing in my installation, I have decided this is a professional software engineering environment which I don’t need. I am deinstalling and going back to Strawberry. Thanks.

Possibly a conflict with the older version if you didn’t remove it or disable it. Since it ran the first time, it might also be that your persistent environment wasn’t changed by the installation command you used. If you use the State Tool with the defaults, the virtual environment will only persist for the first use, and you have to restore the virtual environment each time you resume using it with another State command.