'Your First Project' docs could be expanded a bit

I followed (somewhat blindly) the instructions on the doc site for State CLI Tool → Your First Project and got into a bind since it doesn’t tell you about orgs or authentication when you need to know about it.

I did the ‘state init,’ making up an org name and project name. FIne, no problem. Would have been helpful though to have had a hint to create a directory to hold the activestate.yaml that was generated. (the hint at the beginning of step two “switch to the directory where the project was initialized” comes too late.)

I tried the next instruction for ‘state push’ and get an error Authentication failed. At least the error points you to ‘state auth’ which then worked fine.
Back to ‘state push’ which now it fails for

x Failed to create a project my-org/test
x Permission denied. You are not a member of this organization.

So I log into the website and poke around until I find where I can create an organization. But that fails for “That name is no longer available.”

Apparently my aborted ‘state push’ has invalidated the name I picked.

So before doing the state init, you should create your organization on the website (didn’t check if the CLI has a way to do this). And before doing the state push, you need to do state auth.

1 Like

Great feedback Greg!

I have passed this along to the product and dev teams working on this.