XML::LibXML fails to validate an XML String in utf8::Is_utf8 mode


I tried to report this bug over there too, bug the CPAN RT BTS seems broken.

I would report it here too, but I cannot see how to attach my example files.

I set up a minimal set of files to reproduce the bug, but neither CPAN, nor Activate MX, nor this forum seem to accept it.


We don’t have a way to accept language bugs because we don’t patch the code if the bug is real. Reporting the issue upstream on CPAN is the correct venue.

I wish I could. I tried to but only got a blank “Details panel” and no indication on what to do here:

Active bugs for XML-LibXML


Active bugs for XML-LibXML


What am I missing?

Can you get to the general query page, and from there to the XML-LibXML module?

If you can’t, try from a level higher up that isn’t applying the “guest” user and see what happens from “Don’t have an account but want to browse bugs?”.

If you can’t get that, you might have a firewall or proxy server preventing access to Request Tracker — Best Practical Solutions or preventing redirects to the short form URL.