Unable to install active perl on Mac

I previously installed Active Perl 5.28 using a standard package download. Now I’m trying to install Active Perl 5.36 using Terminal and it doesn’t work:

sudo sh <(curl -q https://platform.activestate.com/dl/cli/_pdli01/install.sh) -c’state activate --default DunkinPerl/ActivePerl-5.36’
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4653 0 4653 0 0 18318 0 --:–:-- --:–:-- --:–:-- 18318
sh: /dev/fd/63: Bad file descriptor

Hi DunkinPerl,

Could you let me know what Mac hardware (particularly architecture) and OS version you are running?




I have an iMac Retina 5K, 27-inch, Late 2015 w/3.2 GHz Quad-Core Intel Core i5 running Big Sur (v11.6.7).


Hi @DunkinPerl, could you try running the command without sudo please? We do not require elevated permissions, in fact we discourage it as it tends to lead to permission issues down the road.


I initially ran w/o sudo but nothing happened so I tried sudo and got the file descriptor error. Here’s all I get when running w/o sudo:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4653 0 4653 0 0 16737 0 --:–:-- --:–:-- --:–:— 16677

There’s no other feedback reported as to whether the install failed or was successful.

  • Phil

Hi Phil,

That’s strange. Are you using the standard terminal and shell or something custom?

Perhaps worth first manually downloading the sh file and then again manually invoking it, eg.

cd /tmp
wget https://platform.activestate.com/dl/cli/_pdli01/install.sh

or if that doesn’t work, try curl instead:

cd /tmp
curl -O https://platform.activestate.com/dl/cli/_pdli01/install.sh

If that doesn’t work; perhaps your system is for some reason more aggressive about downloaded executables. See if System Preferences > Security & Privacy makes any mention of the attempt?

I got the following error when running the wget command:

OpenSSL: error:140773E8:SSL routines:SSL23_GET_SERVER_HELLO:reason(1000)
Unable to establish SSL connection.

The curl command worked and downloaded install.sh. However, that script defaults to using wget so I had to modify it to use curl instead. Then the State Tool was installed and I was able to download my project.

Currently I’m dealing with errors running one of my old scripts, but that’s another issue.

Thanks for the suggestions to help me get things started.

Phil T.

That error message suggests that your last OS update did not upgrade your version of wget. Which seems odd, but maybe you added wget as a separate utility.

That error message is a known issue with old versions of wget. Up to version 1.14, wget only has support for SSL2/SSL3, and our site will not allow connections on those protocols.