Teacup install is not working

Hello. Previously install of packages using teacup was working, this would be a few months ago. (ActiveState TCL 8.5.xxx)

Trying it again now fails and digging deeper, what seems to be going on is that teacup is looking for http://teapot.activetstate.com, which has a 301 permanent redirect. It looks like teacup does not understand that and so fails. Checking with a web browser shows that is all redirected to https, and further it looks like teacup does not understand https (when I added an archive).

My guess: it looks like a web server was changed to have a permanent https redirect, and this has broken teacup.

I should add: this is using TCL 8.5 on windows, 32 bit.

What can I do about this?

Thank you

TEAcup servers were moved to the cloud, but the TEA clients do not support the redirects we set up. We are working on a solution for this issue, and expect to have more information next week.

2 Likes

Do we have update on this ?

New settings are in place now. If you still can’t access TEA servers, your Tcl client is probably too old.

Our cloud hosting provider mandates the use of TLS 1.x, and will not accept connections with SSLv2 or SSLv3. Older TEA clients do not have the necessary version of OpenSSL or the tcl TLS module to support secure connections.