How to install perl Active perl5.36 version?

I am new to this perl , trying to install perl new version .whenever iam trying to install as ana administrator account, its loading on my user profile .I am unable to see that on my controlpanel or on programfiles.can anyone help me on this? @ActiveState-Support

You’ve run the “state activate” command. An activate will set up a single user runtime that is only active in a virtual environment.

An activate should not be used while running as Admin. Once you know more about the command, you’ll understand why.

The State Tool offers many commands. The “activate” command is more or less the same as the “checkout” command without all the defaults. If your use case doesn’t work with an “activate”, consider using the “checkout” command on it’s own and supply non-default values for the options, or consider purchasing the universal installer add-on option with Team Tier.

As has been suggested, you may wish to remove your current installation in C:\Users, and install it elsewhere using:

state checkout <username_or_org_name>/<project_name> --runtime-path <location of folder>

e.g. state checkout nagarjuna227/Perl-5.32 --runtime-path C:\Perl-5.32

However, even after you have done that the Perl installation does not show in your list of installed programs.

You need to add the path to the Perl executable to the PATH environment variable (via sysdm.cpl ,3 → Environment Variables), and select what program to use to open Perl scripts (by right clicking on Properties, and clicking on the Change button).

If you install in say C:\Perl-5.32, then add C:\Perl-5.32\exec to the PATH environment variable. Be sure to add the path to the exec folder, and not the bin folder.

If you use scripts with arguments (switches), then you will most likely need to make some amendments to the relevant open commands in the registry.

Search for the path to the Perl executable, for example C:\Perl-5.32\exec in the registry.

Values for open commands like "C:\Perl-5.32\exec\perl5.32.exe" "%1" need to be changed to "C:\Perl-5.32\exec\perl5.32.exe" "%1" %*, i.e. %* must be added at the end.