Connection to server SFTP and private key

In komodo I can’t connect to an SFTP server using private key authentication.

Error:

‘Private key authentication error.
Key file: ‘/Users/XXXXX/.ssh/id_rsa’
Reason: Unrecognized private key format’

Komodo version - 12.01
OS: macOS Catalina 10.15.7

I am using this key for other purposes so I know it works.

Hi @tgreenemit,

You should only need to add your ssh key to your systems respective keychain (ie. ssh-add path/to/key) and Komodo will use it.

If that doesn’t work, please provide more details about your Komodo preferences server configuration.

  • Carey

I believe it’s related to having a passphrase on the key, as I have tried another IDE that allows a “prompt” for that to be configured and it works. I’ll try removing the passphrase from the key and try komodo again.

@tgreenemit, same instructions apply regardless. ssd-add will prompt you for you keys password before it adds it to your keychain. You shouldn’t need to remove the passphrase.

Again, please elaborate on your configuration and I can help more.

It worked, thank you

1 Like