Can't install using powershell

I use Windows 7. Tried my 1st configuration, build and download. But alas, the download using powershell fails. Here is the result:

C:\Users\David>powershell -Command “$([scriptblock]::Create((New-Object Net.Web
lient).DownloadString(‘https://platform.activestate.com/dl/cli/pdli01/install.p
1’))) -activate-default xxxxxxx/Perl-5.32”
At line:1 char:131

  • … nstall.ps1’))) -activate-default xxxxxxx/Perl-5.32
  •                ~~~~~~~~~
    

Unexpected token ‘-activate’ in expression or statement.
At line:1 char:140

  • … 1’))) -activate-default xxxxxxx/Perl-5.32
  •                ~~~~~~~~
    

Unexpected token ‘-default’ in expression or statement.
+ CategoryInfo : ParserError: (:slight_smile: , ParentContainsErrorRecordEx
ception
+ FullyQualifiedErrorId : UnexpectedToken

I also tried to install the Tools CLI via powershell but get the same sort of thing. I updates powertools from 2.0 to 3.0. I also ran the the powershell command related to TLS that I found elsewhere.

Nothing seems to work!

4 Likes

I have the same issue with Powershell because the server where I need to download this v5.32 of ActivePERL does not have direct internet connection. So the script is not able to download the installer from the Cloud storage.
I need an installer package or instructions how to install with command line parameters (because I managed to download the package from the Clound manually via Browser and Proxy).

Greetings
Frank

1 Like

Version 3 is too old. You need Version 5 in order to have the required commandlets.

See the comment below about access to older versions. For Windows 7, you’re going to need an older version, and might have to be on a paid tier to get what you need at all.

The 5.32 package can’t be installed from a remote download. It’s a boot-strap installer. Without the internet access, it can’t do anything.

The Featured Projects have older versions. There are downloadable MSI format installers in most of the old versions. They lack important features for supply chain management and can’t add modules in place, so there’s a trade-off.

Sorry, I’m new here and you’re kind of talking over my head!

“The 5.32 package can’t be installed from a remote download. It’s a boot-strap installer.” - ???

“Without the internet access, it can’t do anything” - of course I have internet access so I’m not sure what you mean by that.

“There are downloadable MSI format installers in most of the old versions” - I looked at older versions and they all seem to be for Windows 10!

I installed powershell 5.1 and still get errors:

PS C:\Windows\system32> $([scriptblock]::Create((New-Object Net.WebClient).Downl
oadString(‘https://platform.activestate.com/dl/cli/pdli01/install.ps1’)))
Exception calling “DownloadString” with “1” argument(s): “The underlying
connection was closed: An unexpected error occurred on a send.”
At line:1 char:3

  • $([scriptblock]::Create((New-Object Net.WebClient).DownloadString('ht …
  • + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
    + FullyQualifiedErrorId : WebException

can also mean you don’t have a version of .NET framework that supports TLS 1.2, and that might not be available for Windows 7.

Mainstream support (free) for Windows 7 ended more than six years ago, and we stopped doing free versions of ActivePerl for Windows 7 shortly after. As I said, you probably want an older version, but older is relative, and the ones you want are a lot older than the oldest available for free now.

Have you tried a Strawberry Perl? Strawberry operates like we used to do, and they are a library of static downloads that never changes, available with no support. No support might not be an issue for you, since you’re running an O/S that also has no support. They still have their Windows 7 builds from 2016 and earlier available for download.

Yes I tried Strawberry but it is 500 meg. Re Win 7 free versions etc not supported., I was able to build a Win 7 version, but just could not use the powershell command to install. So it would appear that Win 7 is supported! Odd, I’ve probably installed a million files over the years but have never a system like this. Maybe it’s a Win 10 (which I have never used) thing.

Interesting is that I can install perl in Linux for about 30 meg.

Offline installers are a must for enterprise environments. Is there a way to generate one?

Offline installers exist for 5.28 and lower, but do not exist and cannot be generated for 5.32 or 5.34.

Well Powershell 5.1 is really out of date. That’s what known as “Windows PowerShell” and they are up to 5.2 now. But Microsoft released the source to the open source community. Now Microsoft/PowerShell on GitHub.com is up to 7.2

That being said… I have all that and I can’t install with the provided script either.