Installing Perl on Windows 8.1

I have seen similar questions posted, not I am not seeing an answer that solves my problem. I am on Windows 8.1. When I try to install Perl, I get this error:

C:\Program Files\PowerShell\7>pwsh -Command “& $([scriptblock]::Create((New-Obje
ct Net.WebClient).DownloadString(‘
5773.1649108042_pdli01/install-latest.ps1’))) -c’state activate --default sbryce
MethodInvocationException: Exception calling “DownloadString” with “1” argument(
s): “The SSL connection could not be established, see inner exception.”
InvalidOperation: The expression after ‘&’ in a pipeline element produced an obj
ect that was not valid. It must result in a command name, a script block, or a C
ommandInfo object.

When I check to see what version of TLS Powershell is using, I get this response:

C:\Program Files\PowerShell\7>pwsh.exe -command [Net.ServicePointManager]::Secur

I don’t know what the system default is, or how to find out, but I do have TLS 1.2 enabled.

I was ready to switch to Strawberry Perl, but it won’t install all the modules I need, and I can’t get Apache on my local machine to find it.


We haven’t supported a build for Windows 8.1 in quite a few years. 5.34 definitely is not supported on it.

The reference to Apache also raises a flag. We haven’t ever built Apache, so modules like mod-perl that are Apache plugins were not available from us. Which modules were you looking for?

So it looks like I will need to upgrade to Windows 10. I have not had success with that either, but I will try to work that out.

I am maintaining 2 legacy web sites that use CGI, so I am trying to create a similar environment on my local machine.

I currently have Perl 5.28. For some reason, Apache on my local machine cannot find Perl, but that is a Windows configuration question, and not a Perl question. This is a recent problem, and I’m not sure what is causing it. If I need to, I suppose, I could use the shabang for that, though the shabang is different on the server, so I would need to change it before uploading scripts.

I don’t need any additional modules right now, but with PPM no longer being supported, loading new modules is bound to be a problem eventually. Any new Perl installation will need quite a few modules installed. I tried installing Session::Token in Strawberry Perl, and it wouldn’t load. CGI loaded. I have not tried anything else.

While I can understand the advantages of the new environment for people working on new projects, it has made things difficult for those of us who are maintaining legacy code.

I have a temporary fix, that at least gets me back to being able to maintain my CGI sites. I found the windows configuration issue that was preventing Apache from finding Perl. However, I had it pointing to Perl 5.28, which does not have Session::Token installed. I then pointed it to Perl 5.16, and everything is running. This will work until I need to install any new modules.

The longer term fix just may involve replacing my computer. It won’t support Windows 11, and may not support Windows 10.