Installation problem with Catalina on macOS

I really love Komodo Edit - thanks. But since I installed fresh Catalina, I can not install any of Komodos…

It says: “Komodo IDE 12” can’t be opened because Apple cannot check it for malicious software.

This software needs to be updated. Contact the developer for more information.

Safari downloaded this file yesterday at (sep 27,2020) 23:34 from .

What can I do? I’ve clicked all agrees and allows I got… I turned off firewall and FileVault, no idea what else I could do…


Hi @aniawerner

Thanks for writing!

You’ve encountered macOS’s Gatekeeper feature. You can disable Gatekeeper, install Komodo and then re-enable Gatekeeper afterwards. Sadly, we don’t currently plan to integrate Gatekeeper support.

To enable Gatekeeper, open and type:

sudo spctl --master-enable

… and then press the Return key. You’ll be prompted for your password, which you’ll need to enter to proceed.

To disable Gatekeeper, use command:

sudo spctl --master-disable


It looks like I have to type it each time I want to open Komodo. Ech, technology of XXI century…

Hi @aniawerner!

Oof! That doesn’t sound good.

@careyh: can you suggest anything else? I thought that would fix the issue.

1 Like

Just not exiting the Komodo anyway, and have to make the note with a command. Funny, how overcomplicating sends back to analog roots and manualing :smiley:

Hi @aniawerner!

I made the classic mistake of reposting an answer without exploring myself. cough

Here’s what you should do.

  1. Open Komodo IDE

  2. Click OK the warning message that appears.

  1. Open the Security & Privacy pane of System Preferences and click the Open Anyway button.

  1. Click through the confirmation afterwards.

Now you should be able to run Komodo without warnings.