Build Error: importlib-resources 1.4.0 for Python 3.8.2 on Windows

Looking for help with this importlib-resources package that is failing to build in my project. In the last build of this project, this package built fine and I have checked and it seems that no package versions had changed between the two that I can tell.

I was investigating why the last version of this project failed to install in Windows 7, in the same fashion that this project failed: Python Installer Error

Following this lead that seemed to fix this person’s error, I added pypiwin32 (auto), testpath (auto), and win-unicode-console (auto) and now I run into this new failure of importlib-resources.

Runtime Details

  • ActiveState
  • Language - python 3.8.2
  • Platform - Windows

Failing Packages

  • importlib-resources 1.4.0


  • Build failures: importlib-resources
  • Test failures: importlib-resources

Hi @justin-charron! Thanks for writing!

I wonder if it’s because importlib-resources and importlib-metadata are different versions. I’ve forked your project and am trying a build where both are pinned to 1.4.0

If that fails, I’ll take it up with our dev team. :slight_smile:


… and it did fail, but this time it was setuptools that failed. I’ll still talk with our team, but I’m also testing to see if an older version of setuptools is what’s needed to let the build complete.

Aha! It worked.

@justin-charron, you can fork a copy of it here:

Thank you! I have updated my repository to the manual versions of the mentioned packages, and will see if it passes the build then. I will update later on if I am still running into the Windows 7 installation error which led me to add these packages in the first place.


1 Like