Build Error: Compress-Raw-Zlib 2.101 for Perl 5.32.1 on Windows

Looking for help with this package that is failing to build in my project.

Runtime Details

  • ActiveState
  • Language - perl 5.32.1
  • Platform - Windows

Failing Packages

  • Compress-Raw-Zlib 2.101

Compress-Raw-Zlib 2.101 Failed
Attempt to do View Logs hangs with, Connecting …

I tried to add to my project because:
C:\apps\devop_tools\perl.as532>cat c:\temp\
use strict;
use Compress::Zlib;

C:\apps\devop_tools\perl.as532>bin\perl.exe c:\temp\
Compress::Raw::Zlib version 2.101 required–this is only version 2.093 at C:/apps/devop_tools/perl.as532/site/lib/Compress/ line 11.
BEGIN failed–compilation aborted at C:/apps/devop_tools/perl.as532/site/lib/Compress/ line 11.
Compilation failed in require at c:\temp\ line 2.
BEGIN failed–compilation aborted at c:\temp\ line 2.

Options ?


It looks like this was caused by a transient error. I’ve confirmed that rerunning the build works as expected.

If you make a change to your project, it will rerun and should succeed.

Thanks for the quick response….that worked.