Other Linux

any other Linux distro.

Unable to view platform.activestate.com

I am using the Chrome browser on a Google Pixelbook. platform.activestate.com has given me a blank page each time I have tried to access it, today and yesterday. In the meantime, my Android tablet accessed it with no problem.

Komodo won't start on linux due to missing symbol


Komodo won't start on linux, complains about gdk_window_get_visual symbol


On certain older (mostly RedHat based) linux distros Komodo will fail to start with the following error:

undefined symbol: gdk_window_get_visual

To fix this error you simply need to install the "gdk-pixbuf2" package. The name varies per distro, but searching for "pixbuf" should get you the right package name.

Corrupted Files when running the ActivePerl Linux installer


When I run the installer, it reports that several files are corrupted. I see this error:
This installer package does not have the expected content. Please try to download a fresh copy of ActivePerl from ActiveState's website at activestate.com. If you still have problems please contact us at SupportEmail.

How do I fix this?


---Updated 10/18:
This FAQ applies to ALL ActivePerl Linux tarball installers.
A link to a current version has been specified solely for convenience
There are two possible causes.

1) If you used the command line "tar" to extract the archive, and tar reported this:
"tar: Removing leading / from member names"
the version of tar you have installed is removing leading slashes by default as a security measure. This will break the ActivePerl installer. Delete the extracted folder and run tar with different options.
"tar -zxPf (filename for the ActivePerl installer tarball with extensions.)"

2) If you allowed your browser to extract the tarball, it will have use the Linux Archive Manager. Trash the ActivePerl folder you extracted. Download a fresh copy, and do not open the Download with the Linux Archive Manager.
Go to a Terminal Window, and extract the file on the command line, using GNUtar instead:
You may still hit the leading slash issue if your tar has that default behaviour.

Installation of tcl8.5 (32-bit) on ubuntu 12.04 64-bit - Any issues?

- Downloaded "ActiveTcl8. "
- run the install.sh but, that failed with error saying ./payload/bin/wish8.5 - no such file or directory
- I have manually install tk from ubuntu repos and have changed the install.sh to point to /usr/bin/wish8.5


(i) The above steps helped me get the GUI for installation but, installation failed when it tried to open teacup with error "no such file or directory"

ppm install failed: 503 Service Unavailable

I recently had to reinstall our ActivePerl 5.16.3 installation (which went fine) and then reinstall the CPAN modules that we use. I do this by doing a series of 11 ppm calls.

Ten of the ppm invocations executed completely correctly - so there shouldn't be a connectivity issue - but one of them failed. I was unable to install Config::Simple, getting the message below:

ppm install Config::Simple
Downloading ActiveState Package Repository packlist...done
Updating ActiveState Package Repository database...done
Syncing site PPM database with .packlists...done

how to install activepython on mint linux

Hi all!, I want to install activepython 3 on an old Pentium 3 PC which is running Linux Mint 12 OS, problem is, I don't know how to handle the .tar.gz to make it happen. Any help appreciated.

Thanks Malcolm

Problem with PPM - unable update installed package?


I have mistake with ppm, I use "(v5.14.1) built for i686-linux-thread-multi - ActiveState and PPM V4.13 for Perl"


I try update de package, my first feeling is good, but i do not understand why PPM install new version about pkg and keep old pkg, for me is not a update system, I read the manual before writing this.

I try in preferences unlock the PERL area, I didn't do this? I try sudo, no change. When I quit the gui PPM on my terminal have this text, maybe have probleme?


Community Edition TEACUP problems with upgrade of Ubuntu Linux from 10.10 to 11.04

I had ActiveTcl8. installed on Ubuntu Linux 10.10, 64-bit and all was fine. When I upgraded Ubuntu to 11.04, 64-bit, but left the Active TCL install intact, things stopped working with the package repository. It no longer found the module "sound" when I ran tclsh. It also would not find snack. I used teacup and tried to install that module (teacup install sound) but it said it couldn't find it. Then I tried teacup search sound. That found it. So, next I did a teacup get sound and used the resulting file name on the teacup install command.

Minimal Install

I would like to install AP on a Linux embedded system
and so I'd like to minimize the disk footprint. I know
I can delete the man pages and the html help. What else
can I take out for a minimal perl install? How about
/lib/site_perl? Can I take anything out of /lib/5.x.x ?

ActivePython 2.5.1 & cygwin

I can't seem to call the Python interpreter (via python.exe) -- It appears to find python in the correct path with 'which python', but when executing python, python -v, python -dv, it just appears to hang.

It works from cmd. What might it be doing differently with cygwin?