Debian / Ubuntu

ActivePython 3.4

I am developing a MySQL application. From what I can see, MySQL only supports Python 3.4. What is the last ActivePyton release of Python 3.4 and where can I get it?

Installing active perl in lubuntu: Paths? Man?

i just installed active perl, and it went without a hitch, except... i have no idea how to set the PATH and MAN variables as suggested in the documentation or the prompt after installation. it doesnt go into much detail and assumes the user knows what to do. well i dont know what to do...

Corrupted Files when running the ActivePerl Linux installer


When I run the installer, it reports that several files are corrupted. I see this error:
This installer package does not have the expected content. Please try to download a fresh copy of ActivePerl from ActiveState's website at If you still have problems please contact us at SupportEmail.

How do I fix this?


---Updated 10/18:
This FAQ applies to ALL ActivePerl Linux tarball installers.
A link to a current version has been specified solely for convenience
There are two possible causes.

1) If you used the command line "tar" to extract the archive, and tar reported this:
"tar: Removing leading / from member names"
the version of tar you have installed is removing leading slashes by default as a security measure. This will break the ActivePerl installer. Delete the extracted folder and run tar with different options.
"tar -zxPf (filename for the ActivePerl installer tarball with extensions.)"

2) If you allowed your browser to extract the tarball, it will have use the Linux Archive Manager. Trash the ActivePerl folder you extracted. Download a fresh copy, and do not open the Download with the Linux Archive Manager.
Go to a Terminal Window, and extract the file on the command line, using GNUtar instead:
You may still hit the leading slash issue if your tar has that default behaviour.

Unable to install, due to invalid directory choice

I can get the ActiveTcl installer (graphic interface) to run, but I'm unable to complete installation due to "/opt/ActiveTcl-8.6": permission denied. How can I overcome this?


Traceback Error from Python2.7 and 3.3 Interactive Shell Prompt

Just successfully activated my ActiveState Komodo 8.x and tried to write my first interactive shell program. But when I navigated to Tools -> Interactive Shell -> Start New Python3 Shell, viola! I get series of traceback something looking like:

Traceback (most recent call last):
File "/root/Komodo-IDE-8/lib/support/dbgp/bin/py3_dbgp", line 305, in
sys.exit( main(sys.argv) )
File "/root/Komodo-IDE-8/lib/support/dbgp/bin/py3_dbgp", line 169, in main
File "/root/Komodo-IDE-8/lib/support/dbgp/bin/py3_dbgp", line 151, in _fixencoding

linux perl5.16.3 install / run script error

or more to the point, won't run script.
error message;
localhost gary # /home/gary/Perl/ run
bash: /home/gary/Perl/ /opt/ActivePerl*/bin/perl^M: bad interpreter: No such file or directory
localhost gary #

i did the; chmod +x /home/gary/Perl/

The shabang line to; /opt/ActivePerl-5.16/bin/perl
(thats where the perl install lives)

tried to run the bash shell over it to see it;
'perl /home/gary/Perl/'

Recoamimdations from google;

So whats up, how do i run perl script in linux - mint - mate

Install Error Message / Linux

os / debian - mint - mate,

very interesting error message;

I put into the terminal;

localhost gary # /home/gary/Downloads/ActivePerl-

(perl install error,)

env: perl/bin/perl: No such file or directory

Unable to install teapot, while installing ActiveTcl8.6 in ubuntu 10.04 "


I am trying to install TCL package in my Ubuntu 10.04 machine. I have downloaded ActiveTCL_8.6 and installing this using "./" command. TCL installation is succesful, But while installing "teapot" I am getting following errors.

TEA Package Management - Standard Repositories.

TEAcup @ /opt/ActiveTcl-8.6/bin/teacup
Create repository: /opt/ActiveTcl-8.6/bin/teacup: /opt/ActiveTcl-8.6/bin/teacup: cannot execute binary file
Aborting TEApot setup

Without this teapot package I am unable install some libraries.

cpan fails to complete download

When I try to install some CPAN modules, it starts to download and then hangs.

# cpan Template
CPAN: Term::ANSIColor loaded ok (v4.02)
CPAN: Storable loaded ok (v2.39)
Reading '/root/.cpan/Metadata'
Database was generated on Wed, 10 Jul 2013 10:41:02 GMT
CPAN: LWP::UserAgent loaded ok (v6.05)
CPAN: Time::HiRes loaded ok (v1.9725)
Fetching with LWP:


if I try to do get the same file via wget you can see that it gets a packet or two:

ActivePython 2.7 not found under Wine


i'm running Wine 1.6 on Xubuntu 12.04 and can't find ActivePython 2.7 at the Wine menu. In addition, when I try to install PyCrypto 2.1, an error message pops up: "Python version 2.7 required which was not found in the registry.

Here's what I did to install ActivePython (if it's relevant): a) downloaded AP, b) run "tar xzf ActivePython-" + "cd ActivePython-" + "./" in terminal.

can you please help? thanks!