Python install immediately fails

Posted by ricknak on 2017-05-18 15:46

I had AP installed and running just fine. I d/l'ed 2715, and tried to install it after uninstalling 2714 and rebooting. I removed c:\python27 completely.

All options (Typeical, Custom and Complete) immediately exit with an error and no system changes. I d/l'ed another copy, and it is identical to the first copy.

I obtained another copy of 2714, but it likewise ends prematurely with an unknown error.

Any suggestions? There is plenty of disk space, so that's not the problem.

ActiveState Staff
Fri, 2017-05-19 23:30

One thing I can think of is are you installing it in admin mode or regular user mode?

There should be an installer log located at this location when you install. If you open it, what error messages are in it?

ricknak | Sat, 2017-05-20 08:20

The installation is done in Admin mode.

There's no install logs that I can find in appdata\local\temp . When the installer is run, as soon as the installation type (i.e., typical) the installer immediately exits.

Any more suggestions?


ActiveState Staff
Mon, 2017-05-22 08:20

I'd like to confirm how much disk space is on your system. The reason I ask is because recent 27xx releases are much larger than older ActivePythons as it contains 200+ more packages. It's mysterious that installing 2714 is also failing.

If you have a virus scanner that is running, does temporarily disabling it help? Some virus scanners block installation to protect the system.

Also, if there's no log, one thing you can try is enable logging. This article from Microsoft has points on how to enable logging when installing. Please take extreme care as it requires modifying the registry:
What I would strongly advise is to backup your registry before modifying it.

ricknak | Mon, 2017-05-22 13:25

Disk space isn't a problem; it's over 700 GB free. Here's the pertinent part from the installer log. It happens with 2714 and 2715:

MSI (c) (38:04) [17:00:56:881]: Doing action: CheckInstallDir
Action 17:00:56: CheckInstallDir.
Action start 17:00:56: CheckInstallDir.
MSI (c) (38:2C) [17:00:56:881]: Failed to marshal script action.
MSI (c) (38:2C) [17:00:56:881]: Failed to marshal script action.
Action ended 17:00:56: CheckInstallDir. Return value 3.
MSI (c) (38:04) [17:00:56:897]: Doing action: FatalError
Action 17:00:56: FatalError.
Action start 17:00:56: FatalError.

There's perhaps a dozen log lines that follow these.

The C:\python27 direcotry did not exist at first, got the error, then manually created the directory, and still got the error.

What to do now?


ActiveState Staff
Tue, 2017-05-23 13:07

I'm assuming that you're either installing ActivePython on Win 7 or Win 10. But if not, which Windows are you using?

Were there any Windows updates that were added between when 2714 worked and when 2714 & 2715 are now not working? If so, what were they?

Googling around, this type of error can happen if the Windows Scripting Host got corrupted. When I try to install 2715, I have no problems.

I got no confirmation if there was a virus scanner on your system and if disabling helped? Also is the virus scanner set to block vbscript? The installer needs it enabled in order to run.

Advanced Installer also has a suggestion to what to check and try:

This is a bit of a longshot, but could your system possibly be infected with a virus? Viruses can prevent programs from behaving properly.

ricknak | Fri, 2017-07-21 09:26

To recap, 1.
I am running the installer as an Admin,
2. plenty of disk space (700+ GB free),
3. anti-virus software is turned off,
4. No apparent virus infections
5. Log file us being created
6. Unsure about what Windows Updates may have been installed in the interim.

A 12K line logfile is created, and each log appears to show the same problem. "CheckInstallDir" appears to be failing. I've manually created the ActivePython 2.7 direcotry that would be created to see if that would help, but it didn't.

When running the installer, the failure happens almost instantly, and doesn't matter if I trying the typical, custom or complete install. The install directory is apparently not being created, which fits with the error message.

Interestingly, the ActiveGo 1.8.0 beta appears to be installing properly (!). It has at least started, and is taking its time to install. THis suggests to me that the problem with Python is a corrupted Registry entry of some sort.