SciViews-K

Posted by phgrosjean on 2008-08-18 04:49 |
0.9.33
Philippe Grosjean
Tue, 2013-10-29 04:18
  • : 5.0 - 8.*
  • : 5.0 - 8.*

SciViews-K is an extension for Komodo Edit to transform it into a R editor and GUI. Version 0.9.33 requires R 2.11.1 or higher, and is now compatible with Komodo 8. Web site: http://www.sciviews.org/SciViews-K/

pd | Fri, 2008-11-21 02:00

.

prezez | Mon, 2008-11-24 08:34

pd | Mon, 2008-11-24 08:46

Thank you. Let hope an updated official version will follow

phgrosjean | Mon, 2009-10-05 16:41

A new version with lots of improvements and compatible with Komodo 5 has just been uploaded.

pintarello | Thu, 2009-10-29 02:10

There have been problems with having SciViews K taking to R 2.10.
Please refer to http://community.activestate.com/forum/r-language-sciviews-k-plugin
Massimo

phgrosjean | Wed, 2010-05-05 06:07

Version 0.9.16 has a reworked version of the preference dialog box, especially for configuring the way SciViews-K is connecting to R. It also solves a couple of minor problems of compatibility with R 2.11.0.
Please, update!

Philippe

ericp
ActiveState Staff
Fri, 2010-09-24 17:16

I knew once we started changing the project system for v6 that some
extensions would be likely to break. I don't use SciViews, but
expected it would be a likely candidate, given its ambition.

Philippe, could you get in touch with me, and I can help you with this.

As a first start, please change the maxVersion field in the install.rdf
from "6.*" to "5.*", to at least prevent people from getting confusing
error messages when they upgrade Komodo from v5 to v6.

I expect to spend some time next week on extensions, and will be looking
at this one to help get it ready for Komodo 6.

Regards,
Eric

phgrosjean | Fri, 2010-09-24 20:59

Well, I got a couple problems reported with v. 6, but our trials with beta versions made us to put 6.* in install.rdf because we did not saw at first sight the error messages you mention.

However, given the big changes in the project and toolbox, I expect problems. Thanks to propose help! I must say I am VERY excited by the new implementation of projects and toolbox because it will permit me to include pieces of Komodo toolboxes directly in R packages and implement Komodo-specific items.

Best,

Philippe

phgrosjean | Wed, 2010-09-29 01:05

Uploaded version 0.9.18 tagged with 5.0 - 5.* instead of 6.* until the issues with Komodo 6 are solved...

journeymnn | Wed, 2010-11-03 16:54

Hi there,

I've enjoyed using SciViews-K for some time, but I'm not a programmer, just an academic who uses R. I tried 0.9.19 with Komodo Edit 6 and it didn't work. Could never get the R toolbox to appear.

I backed down to KE 5.2.4, used 0.9.19 and R 2.12.0, and all worked fine except for one thing. I cannot send more than about 9 lines of code to R. Anything more than that and I get the blue error bar in Komodo saying "R is calculating...(if it takes too long, etc)" and nothing happens. I can click on another single line of code, and it will get sent just fine. I've tried reinstalling everything so many times my head is spinning.

Any suggestions would be welcome, and I guess there are still issues with KE 6, 0.9.19 and R 2.12.0 communicating properly.

Thanks.

goodwinas | Thu, 2010-11-18 17:09

Here’s the detailed steps I took to get SciViews-k working with Komodo Edit 6.0.1, on Windows 7 64bit. There may be a more streamlined set of steps, but this worked for me and some colleagues.

1. Download and install R 2.12.0 for Windows from CRAN (skip if done)

2. Download and install “Komodo Edit 6.0.1 for Windows (x86)” from here
http://www.activestate.com/komodo-edit/downloads

3. Download and unzip SciViews-K 0.9.19 from here:
http://www.sciviews.org/SciViews-K/index.html

4. Follow all the instructions on the SciViews web page and the ReadMe.txt in the unzipped folder. This will install the SciViews-k extension on Komodo Edit. However, you won’t see the R buttons in the button bar or get the valuable “R Reference” or “SciViews-K” folders in the Komodo Edit toolbox.

5. To complete the install, go back to the ActiveState Community page and click “Community” then “Community Forums” and search for SciViews-K. Here you should find a link to download “sciviewsk-0.9.19-ko.xpi”. Download and unzip it.
http://community.activestate.com/xpi/sciviews-k

6. Open Komodo Edit and make sure the Toolbox pane is displayed. (either under the view menu or a button on the button bar).

7. Right click anywhere in the Toolbox space and select “Import/Export” followed by “Import kpz Package”. In the “Import a …” window that pops up, browse to the folder where you downloaded and unzipped “sciviewsk-0.9.19-ko” and look in the “default” sub folder (\sciviewsk-0.9.19-ko\defaults and select “R reference (0.9.19)” and click open. It should install R Reference.

8. Repeat step 7 for “SciViews-K (0.9.19)” After this, you should see both folders in the R toolbox, but you may not see the added buttons.

9. Close and re-open Komodo Edit. You should see the R buttons added to the button bar.

10. If needed, be sure to change the SciViews-K settings in Komodo Edit (under the Edit > preferences menu) to point to the Rgui where you installed R (default is : C:\Program Files\R\R-2.12.0\bin\i386\Rgui.exe).

The first time you open R with Komodo Edit, it should install the packages needed to work with Komodo Edit and SciViews-k.

Try changing Server between “socket” and “http” if you have problems with R and Komodo Edit communicating. If you get a socket busy error in R when it starts, then close R and open task manager > Processes. I sometimes see that the Rgui.exe is still running, even though there is no open windows. End the process if this is the case.

If this works for anyone that reads it, post back your experience or inputs on the procedure.

ccario83 | Thu, 2011-01-20 08:10

following goodwinas's post got SciViews-K working with Komodo Edit 6 for me (Ubuntu 10.10, KE 6.0.3, SV-K 0.9.19).

As far as the 9 lines bug, try this (solution found from the R-Forge bug list for sciviews-K):

In Komodo, open the toolbox pane -> click the gear button -> New Macro -> paste the following in the edit box:

sv.command.updateRStatus(true);

sv.prefs.setString("sciviews.client.type",
"socket")
sv.r.server = sv.clientType = sv.socket.type =
"socket";

Then click triggers -> check "Macro should trigger on a ...." and then "On Startup"

Now restart Komodo and it should work, or at least it did for me!

journeymnn | Mon, 2011-01-31 08:02

This tip worked for me. Thanks very much. You ended weeks of minor frustration.

ccario83 | Thu, 2011-01-20 07:37

As a R developer that uses Ubuntu, I must say that Komodo Edit with the SciViews-K plugin is probably the best development environment out there! Thanks for all the great work! I hope to see it incorporated as an official language plugin soon.

That being said, I am having similar problems as journeymnn: R scripts that have more than ~9 lines of code refuse to calculate (they don't appear to be sent to the R terminal). I thought this was related to errors with a file not being found in the working directory, but I'm not sure this is the case anymore.

prezez | Mon, 2011-01-31 05:15

For those who encounter problems with v0.9.19, I have put a mod of the xpi onto R-forge:

http://r-forge.r-project.org/scm/viewvc.php/*checkout*/komodo/SciViews-K...

It seems to work fine with Win7 and Ubuntu, but note that this is a development/debug version (notably it makes R console very talkative at startup). It is somewhat trimmed-down, supports only *socket* connection and does not have some gui modifications (eg. categorised icons).
It uses previous versions of the sv* packages, so before installation, uninstall your current svGUI, svMisc and svSocket packages in R.
You may want to keep the toolboxes from 0.9.19.

phgrosjean | Mon, 2012-12-17 08:38

SciViews-K, in its version 0.9.28 is now compatible with Komodo Edit 7.*. It is a major code refactoring internally. There are still a few gliches, like lost of calltips and completion lists for R language, but I am working on them.