MySQL Database Explorer

Posted by toddw on 2010-06-14 12:40 | Staff Pick!
0.3.1
Eric Promislow
Wed, 2013-02-27 15:28
  • : 6.0 - 8.*

Adds support for MySQL databases to Komodo's Database Explorer component.

Requirements:
You'll need to be using the Komodo IDE 6 or later.

Installation:
In Komodo, open the Tools > Add-ons dialog, then in the Get Add-ons tab search for mysql and then click on the mysql entry in the search results - install and restart. Once installed, MySQL will be one of the available databases to which you can add a connection to. Alternatively, you can install the add-on by downloading/saving the xpi file locally and then opening this xpi file from Komodo's File > Open dialog.

Source
This MySQL add-on is released under a MPL license and all source code for the extension can be found here:
http://svn.openkomodo.com/openkomodo/browse/addons/dbexplorer_mysql

Updates
Version 0.3: Allow hostname to be a file path to local mysql.sock
Version 0.2: Use statically linked mysql library.

toddw
ActiveState Staff
Tue, 2010-06-29 17:39

I've updated the extension to use a statically linked mysql client library (I hope). Can you try it again (use Tools->Add-ons and then "Check for updates").

Cheers,
Todd

wdbaker54 | Wed, 2010-06-30 07:42

Thanks for your work - the extension works beautifully now! I can't wait to do some exploring.

nathan | Thu, 2010-07-01 06:48

Thanks Todd, works for me as well now.

However it's checking for the mysql.sock at /tmp, using MAMP this is not where it's located so I had to make a symbolic link to get it working.

Ie. $ ln -s /Applications/MAMP/tmp/mysql/mysql.sock /tmp/mysql.sock

Other than that, working great.

sharkeyzoic | Thu, 2010-07-15 21:58

Yep, found the same thing on Ubuntu, where it is
/var/run/mysqld/mysqld.sock

Two things would be good here:

* Setting to change unix socket name ... also may have multiple of these if you're running multiple mysqld on the one host.

* Should use TCP if portnumber is set, even if it is on localhost.

cheers,

-----Nick

toddw
ActiveState Staff
Fri, 2010-07-16 11:21

Hi Nick,

You can now (as of version 0.3) specify the local file path to "mysql.sock" in the hostname field.

I'm not sure what you mean by the TCP setting, could you please explain what is needed here?

Cheers,
Todd

sharkeyzoic | Sat, 2010-07-17 21:13

Well, there's two ways of connecting to MySQL ... either using a Unix socket (which has a path) or by using a TCP socket (which has a port number) ...

At the moment, it seems that the Unix socket is used any time the hostname is "localhost" ... I think it'd make more sense to make that explicit eg: show either this:

----------------------------------------------
Database Type: [ MySQL |v]
[*] Unix socket
[ ] TCP socket

Socket Path: [ /var/run/mysqld/mysqld.sock ]
----------------------------------------------

or this:

----------------------------------------------
Database Type: [ MySQL |v]
[ ] Unix socket
[*] TCP socket

Hostname: [ whateverhost ]
TCP Port: [ 3306 ]
----------------------------------------------

It is _likely_ that any time you're accessing a MySQL database on _localhost_ that you could actually be using the Unix socket instead, but it is not necessarily true, eg: you might be talking down an SSH tunnel, or inside a chroot jail, or whatever. Making the choice explicit clears up all these oddball cases.

[[ I've got Komodo 6.0.0-beta2 for Linux 64 bit here, w/ DBExplorer 0.1 and DBExplorer_mysql 0.2 ]]

cheers,
nick.zoic.org

toddw
ActiveState Staff
Mon, 2010-07-19 10:25

Hi Nick,

Right, I understand what you mean now. I've logged a bug on adding this UI here:
http://bugs.activestate.com/show_bug.cgi?id=87432

Cheers,
Todd

ericp
ActiveState Staff
Thu, 2010-10-28 12:03

http://bugs.activestate.com/show_bug.cgi?id=87432

Also, is anyone using MySQL on Windows with a named pipe, instead
of a socket?

ericp
ActiveState Staff
Wed, 2010-11-10 16:58

It adds an optional Socket field to the Add/Modify Connection
dialog, but it's only enabled for MySQL currently.

You can also get it from the nightlies; first one should be
out tomorrow around 20:00 UTC (Noon Pacific time).

- Eric

wdbaker54 | Wed, 2010-06-30 08:36

I was trying out the MySQL explorer's Query tab and was wondering why ad hoc SQL queries needed the schema prefixed to the table name when the dialog itself states that in the 'Path'? It seems counter-intuitive. Shouldn't that 'Path' form the implicit schema when none is given with any table name(s) in the query?

toddw
ActiveState Staff
Tue, 2010-07-13 14:24

Can you please log this as a Komodo bug at:
http://bugs.activestate.com/enter_bug.cgi?product=komodo

And if possible provide the example of what you need now in Komodo, compared to what you'd expect to be able to use.

Thanks,
Todd

wdbaker54 | Tue, 2010-07-13 14:55

hermann | Wed, 2011-09-07 03:35

When running a query in the MySQL Database explorer, I get the following error message:

Problems running custom action: OperationalError: (1046, 'No database selected')

However the Explorer window clearly shows the selected 'Path'.

xrmb | Tue, 2010-07-20 08:10

it seems that my version 4.1 is not supported. Do I really have to upgrade it? And to what version...?

toddw
ActiveState Staff
Tue, 2010-07-20 09:28

Right, the MySQL add-on is built to work with MySQL 5.

If you would like to use MySQL 4, you'd need to checkout and compile the Python mysql module for your MySQL installation. You should be able to follow the instructions in the Readme:

svn co http://svn.openkomodo.com/repos/addons/dbexplorer_mysql
cd dbexplorer_mysql
more README.txt

Note the README.txt is also online here:
http://svn.openkomodo.com/openkomodo/view/addons/dbexplorer_mysql/README...

Cheers,
Todd

dguiarj | Wed, 2010-08-04 10:20

There is any chance of this add-on works on Komodo Edit any time soon?

toddw
ActiveState Staff
Wed, 2010-08-04 12:57

Sorry, but the database explorer is a Komodo IDE only component, and so all the database specific extensions (like MySQL) will only be provided for Komodo IDE.

Cheers,
Todd

feneric | Mon, 2010-10-11 07:59

Is a plug-in for PostgreSQL, the other big open source database server, in the works?

toddw
ActiveState Staff
Wed, 2010-10-13 17:55

Yes - we do have plans to provide a PostgreSQL add-on in order to support this database in Komodo's Database Explorer.

We've actually started this work already, though it still needs some work to properly handle the PostgreSQL schema DB layout.

Cheers,
Todd

feneric | Thu, 2010-10-14 05:05

Great! Thank you. I tend not to use either MySQL or Oracle too much, but I use PostgreSQL all the time.

PostgreSQL and ZODB, but I recognize the latter is a different kettle of fish.

amurugan | Tue, 2010-10-19 08:09

Do you have a date for when this might happen? ALso if its going to be for Komodo 6.1, does that require having to pay an upgrade fee from 6.0 or is 6.1 considered a patch ? Or will the postgres db extension work with 6.0 also?

thanks

toddw
ActiveState Staff
Wed, 2010-10-27 17:08

Sorry, but I cannot give a definite time frame for this - but yes, it's something we'd like to do.

All minor version updates (i.e. from Komodo 6.0 to 6.1) are provided for free.

Cheers,
Todd

zrusilla | Sun, 2011-02-27 14:06

My $spouse and I would love to see that.

cormanaz | Tue, 2011-08-02 13:51

Using 6.1.2 and not here yet. Would really like to have it.

cgchoffman
ActiveState Staff
Thu, 2013-01-31 12:57

Just came across this conversation. If you wish to make an enhancement request like a Postgres database explorer for example you are much much better off creating an enhancement request here:

I wrote up a request for you guys here: http://bugs.activestate.com/show_bug.cgi?id=97111 Comment further there. This discussion is not actively tracked by the development team. Bugs and enhancement requests are :D

- Carey

hlslaughter | Tue, 2010-11-16 21:40

for the love of god, ship the thing with mysql support!

so much in komodo does not work out of the box, it's utterly frustrating.

bought v6 hoping it fixed a lot of this stuff, but it doesn't.

sigh..

troyt
ActiveState Staff
Wed, 2010-11-17 16:12

There's a license incompatibility issue. We can't ship this extension with Komodo IDE because it makes use of GPL code.

As for the other things that don't work out of the box, please post the details in the support forum or file bugs.

hlslaughter | Thu, 2010-11-18 11:07

Yeah, Komodo is one of the only non FLOSS apps I use, so I'm not at all used to seeing this problem :)

And I'm not sure I'm even interested in working out my issues with komodo6. I've been a user since v3, and with each release, I hope Komodo will become a top drawer PHP IDE. It's so close, but it never quite gets there. And you consistently make minor annoying tweaks, like moving the projects navigation into it's own window, which, when minimized can never be restored (on linux anyway) or breaking tooltips for "imported" libraries.

I am thinking Komodo probably works well for Perl development. It's got some cool tools, like the regex tool, but it's just very frustrating using it for PHP development and expecting it to get better and seeing that it really doesn't get better.

What I want more than anything else in the world, is a tool that integrates code completion along with popup tips for arguments, etc...

Komodo comes very close, but never quite seems to work without a ton of tweaking, reconfiguring, etc...

Just had very high expectations for v6 I guess...

troyt
ActiveState Staff
Thu, 2010-11-18 12:34

...like moving the projects navigation into it's own window, which, when minimized can never be restored (on linux anyway)

I haven't run into this on Linux. The left sidebar opens as expected with "Ctrl+Shift+P", the toollbar button, or "View|Tabs & Sidebars|Places". The Projects sub-pane collapses and expands. Is it maybe the name change of the sidebar from Projects to Places that's causing confusion?

ericp
ActiveState Staff
Thu, 2010-11-18 11:22

Thanks for the feedback. We've also been looking at Drizzle as a
non-GPL'ed spinoff from the MySQL project, which would go far to
solving that issue.

- Eric

scubahubby | Tue, 2011-03-08 09:37

Our mySql servers are set up to authenticate by database. The extension does not allow the specification of the database so it's not usable for me.

adpo | Mon, 2011-10-10 04:50

I have the same issue.

toddw
ActiveState Staff
Fri, 2011-10-21 13:31

We've got this problem logged as a Komodo bug here:
http://bugs.activestate.com/show_bug.cgi?id=90097

You can add yourself to bug cc-list and you'll be notified when it gets fixed.

Cheers,
Todd

ssaccone | Wed, 2011-03-09 16:11

I installed DBexplorer_mysql 0.3 in Komodo IDE 6.1.1. When I try to add a database it would not let me specify the socket, and insisted on using /tmp/mysql.sock (my RHEL system uses /var/lib/mysql/mysql.sock). Rather than change the socket on my system I fixed it using a symbolic link.

Also, is there a way to remove a database connection once you've added it? (I did post this question in the forums, but thought it might get additional attention here).

Thanks.

macarthur | Fri, 2011-05-06 16:40

I have no idea why it's doing it. And it is as it says, even though it _acts_ like it is able to be defined but clearly isn't. As it currently stands, this addon is completely unusable by most people.

Edit, the 'host' is apparently what it wants. It _wants_ you to specify the socket location. I'd rather it be in the _socket_ area that way it's more usable.

drpadm | Fri, 2011-06-17 09:28

I would love to be able to use the MySQL functionality (that is advertised as available). Apparently it is only available as an on.

That said, instruction on how to install it would be helpful. In the requirements section, there is a comment: "You'll need to install the MySQL Client library on your system".

What does that mean? And how does one go about doing that?

toddw
ActiveState Staff
Fri, 2011-06-17 16:15

I've added installation instructions at the top of the page.

The add-on used to require that the MySQL client libraries were installed on your system, but that is no longer the case - so you can ignore that - I've removed that requirement from the top of page.

Cheers,
Todd

thomas@pethub.com | Mon, 2011-08-08 17:43

The instructions at the top of this page are:
In Komodo, open the Tools > Add-ons dialog, then in the Get Add-ons tab search for mysql and then click on the mysql entry in the search results - install and restart. Once installed, MySQL will be one of the available databases to which you can add a connection to.

Unfortunately, typing mysql in the search box, as indicated, produces a page that contains a pointer right back to THIS page... and no instructions along the way...

toddw
ActiveState Staff
Tue, 2011-08-09 10:20

Are you using Komodo IDE 7? I've just added these alternative installation instructions:

You can install the add-on by downloading/saving the xpi file locally and then opening this xpi file from Komodo's File > Open dialog.

Cheers,
Todd

thomas@pethub.com | Tue, 2011-08-09 11:16

Is V7 available? I'm on V6.1.2

I'll try the xpi file for 6.1.2. Thanks!

matel0t | Thu, 2011-12-22 15:23

can i drop databases and tables?

rpickett@l1id.com | Sun, 2012-01-01 18:54

I'm using 6.1.3 build 66534. Fresh install.

I click Tools -> Addons. I search for mysql, first it gave 1 (and only 1) tool: oracle.

Really?

So I installed it, restarted, etc, still my mysql support (not surprised). Tools -> addons -> search mysql, now it has a link that says "see all results (2)" as a link *and that's it*.

I click the link, which brings me to the site and back to this page.

So, how do you *really* install the addon?

toddw
ActiveState Staff
Wed, 2012-01-11 13:34

If the Komodo add-on dialog does not find MySQL, see the "Alternative" method in the installation notes at the top of this page.

Cheers,
Todd

ben101 | Tue, 2012-01-31 10:24

I have tried both methods to install the addon without success. Komodo kept complaining about incompatibility.

Attempt to install manually (download, then File > Open > File > install now..) produced the following error

"DBExplorer_mysql 0.3.1 could not be installed because it is not compatible with Komodo Edit 6.1.3."

I am using Komodo Edit 6.1.3

Has the addon been updated somewhere?

Thanks.

koter84 | Tue, 2012-01-31 11:42

as far as i know this plugin has never been supported in Komodo Edit, only in the IDE.
at the top of the page it even says:
Compatibility
IDE: 6.0 - 7.*

crag | Wed, 2012-08-29 08:08

Using the explorer, I don't see any Views listed? Does it support views; am I missing some setting someplace?

freakmeister | Tue, 2013-09-10 09:31

I think it's working only with latin letters. I'm russian and this is how I see cyrillic letters in my db. Will you add UTF-8 support in future?

??????????? - savepic.su — ?????? ???????? ???????????