TEA discussions

Tcl module management and distribution

Teapot? What Teapot?

I downloaded and installed ActiveTcl 8.5.10, Community Edition, today.
It was installed on a Windows Vista PC with no problems or error messages.
I tried it out on a couple of Tk programs I had written long ago, and they worked.

I became interested in a statement on the web page
http://www.activestate.com/activetcl/tcl-tk-modules
because it discussed the "teapot" program/script/facility, whatever it is.
That's new to me; I think my old ActiveTcl was 8.4 or thereabouts.

Here is what the web page says:

Need to install tclXML 3.2

Hi,
I'm running on Ubuntu, with ActiveState TCL 8.6 I'm doing some basic XML stuff, and all was working okay. I now have some poorly formed XML to deal with, and need some function that is available in tclXML-3.2 (The ability to catch errors without the program abending, basically.) I can only find tclXML-2.6 available via teacup, although I can find the tclXML-3.2 package on the web.

I presume I have to do one of two things...
o install the new tclXML-3.2 package using teacup - if that's possible

Install a package on mac

Hi - I'm new to mac, and trying to install my tcl environment from Windows. For example, I want to install GetOpts package. teacup can't find it, so that's that.

On Windows, I can put a package into the tcl/library directory and it just works. Can I do this on mac? Where is the equivalent directory, where the packages are stored? I have tcl version 8.4, 8.5 and 8.6 installed (on top of each other), so I'm hoping this technique will work on the 8.5 directories.

Another approach might be to be able to use teacup to install local packages, but I can find no help on how to do this.

TCL Registry Package

Dear Everyone,

I have a problem with registry package. Now, I am using tcl 8.3, reg v1.0 and win7 64bit and administrator access. I am using program that has Tcl built into it. I have tried changed or replaced the latest version (8.3.x/8.4/8.5/....) but still does not work. Just let you know that I can using for package get and delete but failed if using keys, set, type and values package. Please follow the script below;

#==========================================================
package require registry 1.0
set regPath {HKEY_LOCAL_MACHINE\SOFTWARE\TESTS}

Windows install library setup

I did an install of ActiveState ActiveTcl 8.6.1.0 (64-bit) using all defaults. I installed as admin.

I attempt to run a piece of known good TCL code and receive the following error message from wish86 or the console.
can't find package Iwidgets 4.0

I found the hint below from a similar thread but after a few attempts I realized I do not know what to set the values too.
"you can set ITCL_LIBRARY and ITK_LIBRARY"

old version of dom/xml included in 8.6.1 for windows (32-bit) - with 'unknown method'

Hi!
I posted this at the discussion forum, but I now see that support would be a better place.
I repost it fully .

I got some problems with using dom, installed via teapot
on win2012r2 and tcl 8.6.1

ActiveTcl8.6.1.0.297577-win32-ix86-threaded.exe

I get unknown method thrown by dom 2.6 on win2012R2
which i do not get with tcl 8.4 on the same machine

I also would like the dom package to be upgraded to 3.2. 2.6 is _really_ old

test with 8.4
d:\apps\sattmatewcs\sattmatewcs_dstr\bug_tcl>tclsh test_tcl.tcl
8.4
local/stingray/repository/idf

change path to use 8.6

RESOLVED SITE ISSUE (was "getting HTTP 503 Status code")

Trying to install Window Expect by running teacup install Expect command for Win7 and getting the following:

C:\Tcl\bin>teacup install -v Expect
Resolving Expecthttp://teapot.activestate.com: Retrieving remote INDEX status ..
.
http://teapot.activestate.com: Got Status Failed
http://teapot.activestate.com: Got Status = 503 (503 Service Temporarily Unava
ilable Service Temporarily Unavailable The server is temporarily unable to servi
ce your
request due to maintenance downtime or capacity
problems. Please try again later. Apache/2.2.3 (CentOS) Server at teapot.actives

Teacup proxy problem

Until recently I have been able to keep my ActiveTcl distribution up to date by using teacup via a proxy:

teacup update --timeout 0 --http-proxy echowp.yyyyy.xxxx.com:8080

The timeout is set to zero due to our very slow infrastructure!

Recent attempts to update are now failing:

Problems which occurred during the operation:
* http://teapot.activestate.com :
McAfee Web Gateway - Notification Infinite Proxy Loop The
request should not be filtered more than once. URL:
break_line("http://teapot.activestate.com/list"); For

list of teacup *installed* packages ? list of files/sizes ? guibuilder does not work...

Hello,

I am new to teacup, and I did not find in the help doc how to:

1) list the actually installed packages/profiles on my local machine ? ("teacup list" lists the available packages, without specifying the ones which are actually installed or not)

2) get the precise list of the files included in a given package ? possibly with their sizes ?

3) the application "guibuilder" does not work on my system (Linux 64 Mageia 3, Window Maker, ActiveTcl 8.6) it opens an "ActiveState" little window, and hangs.

Thank you very much ! and congratulation for the great job done on Tcl/Tk !

Unable to install teapot, while installing ActiveTcl8.6 in ubuntu 10.04

Hi,

I am trying to install TCL package in my Ubuntu 10.04 machine. I have downloaded ActiveTCL_8.6 and installing this using "./install.sh" command. TCL installation is succesful, But while installing "teapot" I am getting following errors.

TEA Package Management - Standard Repositories.

TEAcup @ /opt/ActiveTcl-8.6/bin/teacup
Create repository: /opt/ActiveTcl-8.6/bin/teacup: /opt/ActiveTcl-8.6/bin/teacup: cannot execute binary file
Aborting TEApot setup
Done

Without this teapot package I am unable install some libraries.