OS X 10.9 (Mavericks)

Mac OS X 10.9 (Mavericks)

Problems selecting /Library Tcl framework instead of /System/Library Tcl framework

My end goal is to be able to use TkTreeCtrl, and I read using ActiveStateTcl was the easiest option as both brew and macports don't show any available TkTree packages.

I've installed ActiveState Tcl 8.5 and 8.6 on OSX 10.9. When I run a script to print the Tcl patchlevel being used, it returns 8.5.18 which is the version located in /System/Library/Framework/Tcl.framework. How can I get it to select the ActiveStateTcl/Tk located in /Library/Framework/Tcl.framework?

Installed ActiveTCL 8.6.4, python/tkinter still gets 8.5.9

I recently upgraded from Mac OS X 10.8/Mountain Lion to 10.9/Mavericks and then to 10.10/Yosemite. At the Mavericks update my python/tkinter app suddenly stop showing images - a known problem and I've installed ActiveTcl 8.6.4, as well as Python 2.7.10. I'm currently on Yosemite and Python 2.7.10.

When I run tclsh, I get this:

$ tclsh
% info patchlevel
8.6.4

But when I run my app, with these two lines at the beginning:

print "Python:", sys.version
print "Tcl revision:", tk.Tcl().eval('info patchlevel')

I get:

Cannot use Tix with ActivePython 3.4.1.0 for Mac OSX (Mavericks)

Hello,

When I tried to do the following:

from tkinter import tix
from tkinter.constants import *
root = tix.Tk()

I get the following error message:

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>
  File "/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/tkinter/tix.py", line 221, in __init__
    self.tk.eval('package require Tix')
_tkinter.TclError: can't find package Tix

Is there anyway to use Tix on MacOSX? There are no problems using Tix on WIndows 7 version.

Pyknon library - using with Komodo on Mac

I have installed Pyknon on my Mac using 'pip'. This all worked and I can access the extra commands by including an import statement.

However, Komodo does not find the library to import in 'from pyknon.genmidi import Midi'.

Help please!

Robust Python 3 Installation on Mac?

I am trying to achieve a robust Python 3 installation.
This is for learning and personal use only.
My starting point is a MacBook Air with OS X 10.9.2.
From the terminal window Python 2.7.5 works fine.
I installed Python 3.3.5 from python.org
IDLE sees Tcl/Tk 8.5.9 which it reports to be potentially unstable
I installed the recommended ActiveTcl 8.6.1
Python 3.3.5 still sees Tcl/Tk 8.5.9.
Finding that the binding is supposed to be dynamic upon installation I uninstalled Python 3.3.5
I reinstalled Python 3.3.5
Python 3.3.5 still sees Tcl/Tk 8.5.9.
I uninstalled Python 3.3.5 again

Uninstall problems.

I am having issues uninstalling ActiveTCL 8.4. I set the permissions for the uninstall script properly, but it gives me this error, and does not complete:

 dlopen(/Library/Frameworks/Tk.framework/Versions/8.4/Tk, 6): no suitable image found.  Did find:
        /Library/Frameworks/Tk.framework/Versions/8.4/Tk: mach-o, but wrong architecture
        /Library/Frameworks/Tk.framework/Versions/8.4/Tk: mach-o, but wrong architecture
        /System/Library/Frameworks/Tk.framework/Versions/8.4/Tk: mach-o, but wrong architecture
    while executing

Mavericks Uninstall of 8.6

I installed 8.6 not aware that it would not properly be recognized by IDLE within the OS. Followed the directives to the location in Library to run the uninstall script. It states Uninstall file urls... and then exits. All instances of the software still appear to be there, so I'm not certain what has actually happened (am I supposed to manually remove the folders at this point?). Trying to get some clarification on this, as it doesn't seem to match the expected output.

Any advice would be appreciated. Just to clarify I am using sudo and I even went so far as to chmod to 755 for executable.

tkcon on ActiveState Tcl 8.6 under Mac OS X Mavericks

I installed ActiveTcl 8.6 and it works great on my Mac OS X 10.9 Mavericks system. However when I look in /usr/local/bin, I can see both tclsh and wish, but not tkcon.

Tkx not working in Perl 5.16 installation in Mavericks

pvmikev | Fri, 2013-11-29 14:21
When I try to use Tkx in Perl 5.16 (which came installed with Mavericks), I get the following error:

Can't load '/Library/Perl/5.16/darwin-thread-multi-2level/auto/Tcl/Tcl.bundle' for module Tcl: dlopen(/Library/Perl/5.16/darwin-thread-multi-2level/auto/Tcl/Tcl.bundle, 1): Symbol not found: _Tcl_Init
Referenced from: /Library/Perl/5.16/darwin-thread-multi-2level/auto/Tcl/Tcl.bundle
Expected in: flat namespace
in /Library/Perl/5.16/darwin-thread-multi-2level/auto/Tcl/Tcl.bundle at /System/Library/Perl/5.16/XSLoader.pm line 71.

MacOS Mavericks ActiveState Python inoperable

There seem to be multiple problems with 3.3 and 3.2 ActiveState Pythons on Mavericks.

So far I've found that

1) readline needs some low level patch in end user's computers, which end users of Python application are unlikely to have skill set or desire to do.

2) python GUI features don't draw or refresh correctly, for example pop-up tooltips in tkinter don't draw text at all, tree view open/close clicks only refresh seconds or minutes later, etc. Not sure if this is in Python or the 8.6 separate tcl install.